KeepassXC refuses to launch under Wayland-Gnome

Just discovered that my KeepassXC will not launch when clicking on the launcher icon. Trying to run it in a terminal gives:

$ keepassxc
Warning: Ignoring XDG_SESSION_TYPE=wayland on Gnome. Use QT_QPA_PLATFORM=wayland to run on Wayland anyway.
qt.qpa.plugin: Could not find the Qt platform plugin "wayland" in ""
This application failed to start because no Qt platform plugin could be initialized. Reinstalling the application may fix this problem.

Available platform plugins are: eglfs, linuxfb, minimal, minimalegl, offscreen, vnc, xcb.
$ pacman -Si keepassxc
Repository      : community
Name            : keepassxc
Version         : 2.6.6-1
Description     : Cross-platform community-driven port of Keepass password manager
Architecture    : x86_64
URL             :
Licenses        : GPL
Groups          : None
Provides        : org.freedesktop.secrets
Depends On      : argon2  curl  hicolor-icon-theme  libgcrypt  libsodium  libxtst  qrencode
                  qt5-svg  qt5-x11extras  quazip  yubikey-personalization
Optional Deps   : xclip: keepassxc-cli clipboard support under X server
                  wl-clipboard: keepassxc-cli clipboard support under Wayland
Conflicts With  : None
Replaces        : None
Download Size   : 6.17 MiB
Installed Size  : 23.87 MiB
Packager        : Antonio Rojas <>
Build Date      : Sat 26 Jun 2021 12:19:38 PM CEST
Validated By    : MD5 Sum  SHA-256 Sum  Signature
inxi -Fxxxaz
System:    Kernel: 5.14.3-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0 
           parameters: initrd=\enos-gnome\amd-ucode.img 
           initrd=\enos-gnome\initramfs-linux-zen.img rw 
           root=UUID=0d19c35e-8b2b-4844-a2e6-359ae17575e1 rootflags=subvol=@ 
           lsm=lockdown,yama,apparmor,bpf loglevel=3 nowatchdog zswap.enabled=0 
           Desktop: GNOME 40.4 tk: GTK 3.24.30 wm: gnome-shell dm: GDM 40.1 Distro: EndeavourOS 
           base: Arch Linux 
Machine:   Type: Laptop System: LENOVO product: 82A2 v: Yoga Slim 7 14ARE05 serial: <filter> 
           Chassis: type: 10 v: Yoga Slim 7 14ARE05 serial: <filter> 
           Mobo: LENOVO model: LNVNB161216 v: SDK0J40709 WIN serial: <filter> UEFI: LENOVO 
           v: DMCN38WW date: 01/18/2020 
Battery:   ID-1: BAT1 charge: 49.4 Wh (90.5%) condition: 54.6/60.7 Wh (90.0%) volts: 16.8 
           min: 15.4 model: Sunwoda L19D4PF4 type: Li-poly serial: <filter> status: Discharging 
           cycles: 218 
CPU:       Info: 8-Core model: AMD Ryzen 7 4800U with Radeon Graphics bits: 64 type: MT MCP 
           arch: Zen 2 family: 17 (23) model-id: 60 (96) stepping: 1 microcode: 8600106 cache: 
           L2: 4 MiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 57488 
           Speed: 1397 MHz min/max: 1400/1800 MHz boost: enabled Core speeds (MHz): 1: 1397 
           2: 1397 3: 1397 4: 1397 5: 1397 6: 1397 7: 1397 8: 1397 9: 1397 10: 1397 11: 1397 
           12: 1397 13: 1397 14: 1397 15: 1397 16: 1397 
           Vulnerabilities: Type: itlb_multihit status: Not affected 
           Type: l1tf status: Not affected 
           Type: mds status: Not affected 
           Type: meltdown status: Not affected 
           Type: spec_store_bypass 
           mitigation: Speculative Store Bypass disabled via prctl and seccomp 
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
           Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional, IBRS_FW, STIBP: 
           conditional, RSB filling 
           Type: srbds status: Not affected 
           Type: tsx_async_abort status: Not affected 
Graphics:  Device-1: AMD Renoir vendor: Lenovo driver: amdgpu v: kernel bus-ID: 03:00.0 
           chip-ID: 1002:1636 class-ID: 0300 
           Device-2: Chicony Integrated Camera type: USB driver: uvcvideo bus-ID: 1-4:3 
           chip-ID: 04f2:b6cb class-ID: fe01 serial: <filter> 
           Display: wayland server: 1.20.13 compositor: gnome-shell driver: 
           loaded: amdgpu,ati unloaded: fbdev,modesetting,vesa display-ID: 0 
           resolution: <missing: xdpyinfo> 
           Message: Unable to show advanced data. Required tool glxinfo missing. 
Audio:     Device-1: AMD vendor: Lenovo driver: snd_hda_intel v: kernel bus-ID: 03:00.1 
           chip-ID: 1002:1637 class-ID: 0403 
           Device-2: AMD Raven/Raven2/FireFlight/Renoir Audio Processor vendor: Lenovo 
           driver: snd_rn_pci_acp3x v: kernel alternate: snd_pci_acp3x bus-ID: 03:00.5 
           chip-ID: 1022:15e2 class-ID: 0480 
           Device-3: AMD Family 17h HD Audio vendor: Lenovo driver: snd_hda_intel v: kernel 
           bus-ID: 03:00.6 chip-ID: 1022:15e3 class-ID: 0403 
           Sound Server-1: ALSA v: k5.14.3-zen1-1-zen running: yes 
           Sound Server-2: JACK v: 1.9.19 running: no 
           Sound Server-3: PulseAudio v: 15.0 running: no 
           Sound Server-4: PipeWire v: 0.3.35 running: yes 
Network:   Device-1: Intel Wi-Fi 6 AX200 driver: iwlwifi v: kernel bus-ID: 01:00.0 
           chip-ID: 8086:2723 class-ID: 0280 
           IF: wlan0 state: up mac: <filter> 
           IF-ID-1: tun0 state: unknown speed: 10 Mbps duplex: full mac: N/A 
Bluetooth: Device-1: Intel AX200 Bluetooth type: USB driver: btusb v: 0.8 bus-ID: 3-4:2 
           chip-ID: 8087:0029 class-ID: e001 
           Report: rfkill ID: hci0 rfk-id: 1 state: up address: see --recommends 
Drives:    Local Storage: total: 953.87 GiB used: 57.06 GiB (6.0%) 
           SMART Message: Unable to run smartctl. Root privileges required. 
           ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: SK Hynix model: HFS001TD9TNG-L3A0B 
           size: 953.87 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4 
           rotation: SSD serial: <filter> rev: 80050C10 scheme: GPT 
Partition: ID-1: / raw-size: 942.87 GiB size: 942.87 GiB (100.00%) used: 56.74 GiB (6.0%) 
           fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2 
           ID-2: /home raw-size: 942.87 GiB size: 942.87 GiB (100.00%) used: 56.74 GiB (6.0%) 
           fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2 
Swap:      Kernel: swappiness: 20 (default 60) cache-pressure: 100 (default) 
           ID-1: swap-1 type: file size: 10 GiB used: 0 KiB (0.0%) priority: -2 
           file: /swap/swapfile 
           ID-2: swap-2 type: zram size: 7.5 GiB used: 0 KiB (0.0%) priority: 100 
           dev: /dev/zram0 
Sensors:   System Temperatures: cpu: 32.6 C mobo: N/A gpu: amdgpu temp: 32.0 C 
           Fan Speeds (RPM): N/A 
Info:      Processes: 386 Uptime: 2h 18m wakeups: 4289 Memory: 15 GiB used: 2.68 GiB (17.8%) 
           Init: systemd v: 249 tool: systemctl Compilers: gcc: 11.1.0 Packages: 999 pacman: 986 
           lib: 234 flatpak: 13 Shell: Bash v: 5.1.8 running-in: gnome-terminal inxi: 3.3.05

Use QT_QPA_PLATFORM=wayland to run on Wayland anyway.

I am not sure how I am supposed to use this.Tried even the AppImage. It won’t launch and gives the same message in a terminal. Would appreciate any hints/pointers to get KeepassXC back up and running.

Sorry folks for posting before doing some research. Should have known better :blush:

Installing qt5-wayland solved the issue for me. KeepassXC now launches just fine.


That sounds like it should be an optional dependency of something…


It should have been but it’s not listed as such:

Optional Deps   : xclip: keepassxc-cli clipboard support under X server
                  wl-clipboard: keepassxc-cli clipboard support under Wayland

However it is optional for qt5-base it seems:

Optional Deps   : qt5-svg: to use SVG icon themes [installed]
                  qt5-wayland: to run Qt applications in a Wayland session [installed]
                  qt5-translations: for some native UI translations
                  postgresql-libs: PostgreSQL driver
                  mariadb-libs: MariaDB driver
                  unixodbc: ODBC driver
                  libfbclient: Firebird/iBase driver
                  freetds: MS SQL driver
                  gtk3: GTK platform plugin [installed]
                  perl: for fixqt4headers and syncqt [installed]

Now [installed] :slightly_smiling_face:


Ah, that’s where it was hiding. :grin: