KeepassXC Plasma Wayland missing function?

first of all: Happy new year! :clinking_glasses:

I have switched with Plasma from X11 to wayland and discovered that in KeepassXC the Autofill in the Context Menü is missing now.

Under X11, I can right click on an entry in KeepassXC and select “Performe Autotype…” to automatically type username and password in websites and programs.

Under Wayland this menupoint ist missing. Why?
Is this a limitation of wayland?

While I have not yet had any dealings with Wayland, I think that’s a security feature. The architecture of Wayland does not allow random applications to input things into other windows. If that functionality can be separately enabled I have no idea, but I presume that should be possible.

I’m sorry that I have nothing more concrete other than “It’s probably by design”. Maybe you can find information in the KeepassXC documentation?

1 Like

Don’t worry, your answer is better than nothing :wink:

I’m going to look in the documentation of KeepassXC, if I find a workaround for this.

Auto-Type on Wayland:

Thanks to @sammiev for the find.


how did you install the KPUInput plugin? did you install from the AUR because the AUR has keepass as a requirement not keepassxc

You need the AUR package then continue the installation of KPUInput. Actually I did one each way, but you do need both. I tried the plugin on KeepassXC with no luck as the plugin was created by the folks at KeePass.

Thanks for the confirmation, it the plugin doesn’t work with the KeePassXC then I won’t bother as I really don’t feel like switching to KeePass just for this feature

I found a solution that works on my machine.
It is directly from the KeePassXC wiki:

Auto-Type will be disabled when run with a Wayland compositor on Linux. To use Auto-Type in this environment, you must set QT_QPA_PLATFORM=xcb or start KeePassXC with the -platform xcb command-line flag.


Thanks for sharing. That would explain why I didn’t have this issue. I already had that environment variable set for something else.