"kdesu dolphin" doesn't work!

I can’t open dolphin as a root on endeavouros using ‘kdesu dolphin’ command. When I enter it I am prompted to enter my root password, and then nothing happens. No error messages, but dolphin doesn’t open either. This command works perfectly well on other distros.

Entering simply ‘dolphin’ opens it. It is ‘kdesu dolphin’ that doesn’t work.

What am I doing wrong?

1 Like

dolphin is blocked from running as root by the kde developers due to security issues with dolphin when run as root.

If you search around there are workarounds but you really are better not running dolphin(or most other graphical applications) as root.


It was blocked sometime in the past, but I think they soon unblocked it after that. Anyway, in OpenSUSE tumbleweed, which is a rolling distro with latest everything, same as EndeavourOS, this command works.

As far as I know, all versions of suse have a patched version of dolphin. I believe that is the only distro that has it that way by default.

suse is really the only major distro that encourages running graphical applications as root at this point.

1 Like

I see, then how would you run dolphin as root?

Since it is a terrible idea to do so, I am not going to provide instructions for that but if you do a search it shouldn’t be hard to find the answer.


If you must use a file manager as root - I would recommend the TUI application mc (midnight commander).

pacman -Syu mc

As @dalto said, running dolphin as root is a terrible idea.

1 Like

Unfortunately midnight commander is not as convenient as proper GUI.

Anyway, this root blocking thing seems to be only issue with dolphin. When installing endeavourOS I was running thunar under root, with ‘sudo thunar’.

Yes, it is explicitly blocked by dolphin itself.

If one opens a file with kwrite or kate to edit in dolphin.
when you save the file it asks for root password.
so there is no need to run dolphin as root


I don’t disagree necessarily. You shouldn’t really be running GUI applications as root either - just kind of a general rule. MC is still my best suggestion if you insist on needing a file manager to run as root.

What is it you’re trying to accomplish where you think you need to run dolphin as root?

Thanks, indeed, I just checked. I am used to OpenSUSE where it doesn’t do that, and you instead open dolphin as root.


I was trying to edit librewolf.cfg file to enable LibreWolf browser to store passwords. And I edited it with ‘SUDO_EDITOR sudoedit=kate’ command. But that is a waste of time to type this long command, as the need to edit system files comes up frequently in Linux.

Now I have another problem - when I choose to open terminal from drop down menu in any folder or press ‘alf+F4’, terminal doesn’t opens. Anybody has any ideas?

Can’t you just type kate librewolf.cfg ?

In dolphin? If so, run dolphin from the terminal and see if an error shows up in there when you try to open a terminal.

1 Like

When I open the dropdown menu this shows up:

kf.coreaddons: Expected JSON property "X-KDE-Show-In-Submenu" to be a single string. but it is a bool

When I click ‘Open Terminal’, no message shows up on terminal and terminal does not open.

That error is probably not related.

Strange that it is failing silently.

What is your terminal emulator set to in system settings?

Also, have you tried resetting permissions on your home directory? Often running graphical applications as root can break user permissions.

I just opened a cfg file in /etc/pacman.d with kate and deleted a symbol (#, nothing serious) and closed it. It asked, if I want save it. I clicked yes, and it got saved. So, I checked a few other text files, and all of them got saved. Strange that Dolphin can’t be opened as root, but files can be changed without a password!

That isn’t normal. It is possible that either there is group your user account is in that allows that or you have modified polkit rules.

Here is what I get when I try that:

there are also those AUR packages “rootactions-servicemenu”, that include root actions into Dolphin’s context menu.


Terminal emulator is konsole.

How does one reset permissions?

It is a fresh install, btw. I didn’t do much of anything there yet.