Kdeconnect cannot access Primary (top level), Download, Android folders


After doing a factory reset on a Samsung Galaxy S20 FE 5G android phone (USA version) I cannot get kdeconnect to access the following folders: Primary (top level), Download, and Android folders. Before the factory reset it worked to access all folders. All software is up-to-date. On my Samsung Galaxy S21 Ultra all folders are available to kdeconnect, at least for now.

The top level folder used to be accessed and then everything under it was exposed to kdeconnect. That is no longer the case. Kdeconnect has to be given access to each folder as a separate step.

I’ve searched and cannot find any definitive reference to this behavior or if there is a setting that I’m missing. I can understand why vanilla android/kdeconnect might want to protect top level and Android folder access, but there should be a way to turn off that protection. At least for Download. Why Download???

linux kdeconnect 21.08.3-1
android kdeconnect 1.18.0 (on both phones) Tried 1.18.1 but got the same results.

Anyone else notice this new behavior?