Kde6 - Dark Theme broken

Suddenly my dark themed windows look like this:

Loading the default dark theme in KDE Settings won’t help.
Any idea what package is responsible?
Please note that also the EOS-Logo is gone.

Do you still have eos-settings-plasma installed?

Yes, it is installed.

Edit: I just found that SDDM is also broken. It’s a white sceen. Log in is possible though.

How about endeavouros-theming?

It’s also installed.

That is really all we install.

What, specifically, have you tried changing in system settings?

When I found the GUI broken, I tried to reset to default Breeze Dark here:

Are you using kvantum, qt5ct, qt6ct or anything else that modifies qt settings?

1 Like

No. Neither kvantum nor qt5/6ct are installed. I wouldn’t know of any mods to qt settings. Pretty Vanilla Plasma 6.1.0 setup.

Can you try creating a new user and logging into that user account to see if the problem is there as well?

Same for a new created user.

I found the ‘evil doer’:
plasma-integration 6.1.0-2 is broken. I reinstalled
plasma-integration 6.1.0-1 now, everthing is working again.

1 Like

I could assume the evil doer is PEBCAC :crystal_ball:
According to upstream packages:

x86_64 	KDE-Unstable 	plasma-integration 	6.1.0-2 	
x86_64 	Extra 	plasma-integration 	6.1.0-1

You haven’t said you are Unstable. I mean on KDE Unstable :smile: .

1 Like

I picked Plasma 6.1.0 from KDE-Unstable some time ago, then I missed to deactivate it when 6.1.0 became stable. Usually I do stick to stable releases.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.