KDE Wallet Service Login Issue

Hi! :grinning:
After my second login after yesterday’s update to Plasma 5.18 I encounter this problem every time I login:

Screenshot_20200212_213124
I need to enter the password every time I login…

I have the same problem in 3 computers now, I tried to fix that in one of them by deleting the “kdewallet” saved by default using the “Wallet Manager” and creating a new one but the problem persists, I used the info here and here and made sure I have all that is required for it to get unlocked automatically and yet it doesn’t work, then, I looked for that ~/.kde4/share/apps/kwallet folder, so I could delete it, but the kwallet folder doesn’t exist, yet, I searched for it in all folders and found two of those but none is named specifically “kwallet”, they are named “KWallet” so I decided not to mess with them. Given I have the same problem in three computers I guess it may be a Plasma bug, so does anyone know if there’s another way to solve this or if there’s gonna be a solution?, I searched for more info about the problem specifically for the 5.18 version, but there’s nothing, there’s similar stuff about previous (very old in fact) versions but nothing exactly like what is happening to me now.

I am not posting log files as I don’t think they are necessary now, but if I have to I will, just let me know. I checked for PAM errors in the log files and apparently there’s none, but I will post everything if you want me to.

THANKS IN ADVANCE guys! :smiley:

If you are using a wifi connection you could change the “available to all users” option to true in NetworkManager which enables wifi before login. Another solution would be switch the password option to “unenecrypted” in the wifi security tab. Or you disable the wallet master password by setting a blank one.