KDE wallet popup everytime on launch

Every time I boot up, I have to enter my password into this KDE wallet popup. Is there anyway to stop this popup? It is really annoying. It only happens on the first time on launch when I open a chromium app
Screenshot_20220910_100805

kwallet-pam

Installed? https://wiki.archlinux.org/title/KDE_Wallet

I already had it installed and nothing works. I am also using ssdm

Full confession, not using KDE at the moment, but used to. Did you also follow this for automatic login:

The chosen KWallet password must be the same as the current user password.

It should unlock also other services when you login including network/wifi.

Is discord the only app where you have no auto login or also other apps?

Edit: I also had a similar problem that you show here that’s way I suggested the kwallet-pam package, which solved it for me.

Yes my kwallet password is exactly the same as my login password. This occurs for vscode if I launch vscode first instead of discord. I suspect it is something related to electron/chromium apps

1 Like

Just one more question that may help when the next KDE user comes to your help … do you use auto login in sddm or normal session with login password?

I use a login password normally but I have also setup facial biometrics via howdy

Did not know that was possible in Linux! Anyways, perhaps for troubleshooting purpose try to login normal with pwd and see if it works. The arch wiki also mentions something to enable chrome/chromium to use kwallet in the link I posted above. Maybe worth a shot. Good luck!

Clear the password of your KDE wallet. You need password to unlock the wallet, SDDM does it automatically if you use password login. Other ways (autologin, fingerprint login, FACE BIOMETRICS?!) will not unlock the wallet.
Install kwalletmanager, unlock your wallet and change password, when it asks for new password leave both fields blank.

1 Like

Did you set your KDE wallet with blowfish encryption? See this topic:

Looks vaguely familiar :grin:

2 Likes

This fixed it thank you.

Solution:
Install kwalletmanger and change the password to an empty password
For extra security, I enabled prompt on requesting wallet access

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.