KDE Screenshot takes screenshot of the past

Whenever I take a screenshot using KDE’s default Spectacle, it doesn’t take a screenshot of my current screen, but of my screen a few minutes ago.

For instance, if I take a screenshot right after I log in, Spectacle takes a screenshot of my splash screen.

Zoom screensharing also exhibits a similar behavior, where sometimes the windows I have open around 5 minutes ago (and closed before screen share) show up. I’m unsure if these issues are related.

Any help is appreciated.

Now if we could somehow get it to take screenshots of the future… :wink:

But jokes aside, doesn’t happen for me on neither of my 2 computers running EOS/KDE. Although I didn’t take any screenshots the last few days. Was there an update recently?

edit Will try when I’m at home in about 40 minutes or so

Been using kde and spectacle for quite a while never seen that.

Woah! that is quite a feat.
The behaviour implies that spectacle is reading a screen buffer which is a few minutes old.
Assuming you are taking a full screenshot, what happens if you choose rectangular region?
BTW I’ve not seen this behaviour.

I would take a screenshot to demonstrate, but that’s the tool in question.

Attached is a picture taken from my phone. As you see when I press the PrtScr button on my laptop, spectacle activates but it takes a screenshot of my wallpaper, rather than the Firefox window that is open.

The clock in the screenshot isn’t the current time, so the screenshot is “of the past”.

Choosing a rectangular area exhibits the same behavior. It jumps to the wallpaper and makes me draw a rectangle on that.

Strange. I just tried it (while running a timer to see if there is any delay) after updating the system and it works as expected.

Do you have a nvidia gpu?

Looks like you are not alone. There is a first post which provides few solutions.

4 Likes

Thank you.
Removing xf86-video-intel solved the issue.

2 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.