KDE refuses to start spice-vdagent on login

Another new-KDE annoyance. I have 20+ QEMU VMs (just converted from VirtualBox) and all but the KDE ones start the spice-vdagent app upon user login. Spice installs its user startup .desktop file in /etc/xdg/autostart, but for some unknown reason it will not run on KDE unless I open a terminal and manually run it. Note, this is not about the spice-vdagentd.service; this starts, along with the listening socket, just fine. It’s just the userspace spice-vdagent that won’t.

Any ideas??? I ran into similar problems with VMware’s open-vm-tools; that one was never solved.

I use virtualbox a lot and vmware. I always have issues with qemu for one reason or another. One i don’t like is it’s too difficult to get the screen size working i want. On vmware or v-box it is a always correct and done very easily on boot. The screen size matches my monitor size and or adjust appropriately on the fly.

Another issue is getting it to work sometimes without black screen.




I’ve used all (3) at various times, even paid for VMware WS Pro, but I always end up back with QEMU. Other than KDE issues with starting services (or phantom services), the only other problem I’ve ever encountered with QEMU is that xfwm4 does not like to resize the desktop, at least not until a user logs off/on again. In my experience, VMware’s support is not good, and VirtualBox’s documentation is full of features that were sunsetted/abandoned without updating.

Overall, these are all good systems; can’t imagine how hard it must be to maintain something that needs to work with so many different OS’s from gods-know how many years ago.

I don’t what the draw is for Qemu. It’s definitely not my favorite. I can install and test way faster with Vmware and v-box.

My GNOME, Cinnamon, and LXQt installs of EOS work fantastic; no XFCE yet as that’s my main system.

I don’t have any issue with any of the desktops really. I just prefer KDE and XFCE but i do like the others as well.

For me, the original reason was learning, kinda like I tried (and failed) to build a working Gentoo system. Now I have (3) Gentoo systems working and would switch there if EOS/Arch ever kicked the bucket.

QEMU’s interface is definitely lacking compared to the other 2.

Agreed. KDE is definitely my fallback if XFCE were to vanish.

I just find Qemu much harder to work with. Part of it is my lack of knowledge with it compared to the others. But i don’t like wasting time when I’m trying to install and test the live ISO.

Once you’ve built one, especially one that’s only used for booting Live ISOs, you’d find it fairly easy to work with. Definitely a learning curve, but the basic concepts are the same.

Oh i can use it. I just find it doesn’t always co-operate and i cannot set the resoltion the same as i can without issue on vmware or v-box. They both just work.

This is a known bug related to X-GNOME-Autostart-Phase in /etc/xdg/autostart/spice-vdagent.desktop. See bugzilla issue.

So the logical thing is to comment out or delete this line, as comment 13 tried. Apparently it didn’t work for them but it did for me ¯\_(ツ)_/¯.

I’m too lazy to try to understand exactly what it’s doing or why it’s causing issues. It seems like a pretty deep rabbit hole. Well as long as it works I won’t complain.

1 Like

Welcome @Sch :rabbit: :hole:

It was reported in 2021 and the bug is still there…

This problem still exists for Endeavour/KDE. Here’s the bit that finally fixed it for me (referenced here):

add spice-vdagent.service to the end of the Wants= line.

Yep, worked for me as well. I had forgotten about this until I upgraded by Debian VM to v12; the older releases didn’t suffer this bug.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.