KDE proxy settings seem to have no effect

I’ve recently switched from Budgie to Plasma and I have a bad behavior I didn’t have with Budgie.

Setting a proxy server in Gnome/Budgie settings worked well for browsers, but it doesn’t with KDE.

Is there any catch in KDE to make proxy settings work for browsers?