KDE Plasma 6 / Wayland causing application flickering on NVIDIA

EndeavourOS self-updated to KDE Plasma 6 earlier this week. Plasma 6 ships with Wayland by default.

Many of my applications that use Electron (Steam, Discord, Signal, Plex, among others) flickers/glitches badly, to the point it’s unusable. Multiple times over the last week, the system crashed and reset itself while running :disappointed_relieved:.

I have an NVIDIA graphics card and based on my research, Wayland is not yet stable on that platform. The advice is to switch back to X11 in the meantime, until the bugs are resolved.

How do I switch to X11? I edited the /etc/sddm.conf file and rebooted, but it still boots as Wayland:

$ cat /etc/sddm.conf

Update: I used the UI drop-down on the bottom left in the login screen to switch to X11 for the login session.
I thought it’s temporary for the current session, but upon reboot, it looks like the UI setting sticks!

Still not sure why the setting in /etc/sddm.conf is not honored.

Editing sddm config files manually is a good way to get locked out of the GUI session. My advice is to not do it.

It’s good that you found the drop-down menu, and yes, it’s good that it remembers your last choice.

Enjoy using Xorg.

1 Like

:point_up:t5: :point_up:t5: :point_up:t5: :point_up:t5: :point_up:t5:

If you meant to enable autologin for a X11 session then there is something missing here, namely:

User=Name ## Name being your real username


I was getting extremely frustrated with the application flickering on Wayland, so I was blindly following any and all suggestions to switch back to X11. I saw the solution posted here: Is it possible to switch back to X11?

I have a HiDPI monitor, so that dropdown in the bottom left of the corner is tiny. I thought I didn’t have it. That’s why I went searching for alternative solutions. (also the Virtual Keyboard button is right there too, on the bottom left, which confused me).

In the post above, I did not see the fine print that this is only applicable for users that have autologin enabled.
Similar setting in the UI:

I reverted /etc/sddm.conf back to :


How does this happen? I wasn’t aware of any auto updates?

1 Like

eos-update did this automatically.
It runs automatically on every boot of the machine. (which is daily for me)

Ahh, I don’t use that. I believe it offered setup when you first install, but I don’t need an update reminder, so I uninstalled it.

Hello there!
Also had problems with Nvidia and Wayland for a long time, temporarily solved the problem by installing the 535 driver. works smoothly for my 1660 Super almost without issues

git clone https://github.com/Frogging-Family/nvidia-all.git
cd nvidia-all
makepkg -si

You may need to set the adaptive synchronization setting to “off”, if your monitor supports it. it helped to get rid of flickering in games.

Thanks for the suggestion. Older versions of the NVIDIA driver can be downloaded directly from NVIDIA here.

I’m on NVIDIA driver v. 550.67, which is the current version of the latest branch, released on March 19, 2024

v. 535.171.04 the the latest version of the older branch, released on March 21, 2024.

It may be worth trying out the older branch to see if it’s more stable on Wayland. I’ll just miss out on new features and bugfixes for games. Although I’m just as happy on X11 with the newer driver.

Interestingly, the release notes for v. 550.67 show:

Fixed a bug that caused wgpu applications to hang on Wayland.

So you’d think the newer branch is the more stable one on Wayland.

The v. 555 driver releasing beta on May 15th allegedly brings the stability of the 535 driver with the features of the 550 driver for Wayland. Looking forward to it.