KDE Plasma 6 and nerd fonts

I’ve just updated to KDE Plasma 6 and all my nerd icon fonts are missing in KDE applications, e.g., Konsole and Kate:


Looks like it’s already been reported: https://bugs.kde.org/show_bug.cgi?id=478549


Experienced the same. I “fixed”(?) it by selecting NotoMono Nerd Font in Konsole → Edit Current Profile → Appearance.

Nevermind I spoke too soon, the cursor starts trailing behind:

NotoSansM Nerd Font Mono fixes the trailing cursor.

1 Like

That worked for me. I wonder why fonts.conf seems to be ignored though. Maybe a wayland thing?

I’m not having these issues with konsole or nerd fonts.

Well, okay. I did when I first rebooted. To fix it, I just copied my profile and made the new copy as the default. After restarting konsole it works fine.

What icons are those and where do I get them?

Which ones? Hahaha

I’m using a slightly customized version of fastfetch, which is set as my custom fish_greeting in fish shell and all the icons are found in Nerd Fonts.

The one’s you are using in konsole’s menubars.

Ohhh… those are BeautySolar icons. Search for them in icons in colours & themes in system settings.

1 Like

I’m not sure I understand what you had to do with your Konsole profile: you just copied that and no modification?

Oddly enough, yes. I just went to ~/.local/share/konsole/ and duplicated my existing profile and renamed it. I then restarted konsole, selected the new profile and set as default and everything was fine. I did delete the other one, so I’m not sure if that had any impact.

I don’t see how this could solve the problem :wink:

1 Like

Hahaha, I completely understand and agree with you. But it worked. :man_shrugging:t5:

Unfortunately you deleted the old one, otherwise it would have been interesting to see the differences

The only custom thing I have set is the font.

It’s still in my rubbish.

Profile 1 (current profile in Plasma 6).

Font=Agave Nerd Font,15,-1,5,400,0,0,0,0,0,0,0,0,0,0,1

Name=Profile 1

Profile old

Font=FiraMono Nerd Font,13,-1,5,400,0,0,0,0,0,0,0,0,0,0,1

Name=Profile 1

I went through the reported bug (and also commented on that bug):

It looks like it is an intended change in Qt that makes the existing configurations not work anymore, I’ll summarize it as how I understand it:


  • you have an installed font with nerd icons
  • even if you use a font (not nerd, nor patched) that does not provide nerd icons, Qt will look for a font providing that and use that


  • It is not rendered if the current font does not have a nerd icon.

That seems to be intentional (https://code.qt.io/cgit/qt/qtbase.git/commit/?id=a44b6950268214d802bc7ce7df09975261263e31)

For example, concerning what @misanthrope said: maybe “FiraMono Nerd Font” does not provide a specific glyph. Previously, that was rendered taken that missing glyph from another nerd font providing it. Now, that does not happen anymore. On the contrary, “Agave Nerd Font” provides all the needed ones.

As another example (see my comment on the bug):

  • install ttf-hack-nerd
  • set the “Fixed width” font in System Settings to “Hack Nerd Font 10pt” (the default is “Hack 10pt”)
  • make sure your Konsole profile does not specify any font (see the corresponding “.profile” file to be sure) and nerd icons will be shown correctly
  • same for Kate

If you specify, or you had previously specified, any font in those configurations (even “Monospace”) it will still not work. You might have to manually modify the Konsole profile file and .config/katerc and remove the setting for the font.

I haven’t stressed that in my initial post: this “bug” (well, the “new intended behavior”) is only for Qt/KDE applications. For example, Alacritty still works without any intervention.

1 Like

I think this would be as expected, not problem.

Qt simply wanted to directly access a font package containing nerd fonts for some reasons: Performance and simple config. Do not need two separate packages ttf-nerd-fonts-symbols + ttf-hack as they are cumbersome.
A package for example ttf-hack-nerd or ttf-noto-nerd would be enough for Qt rendering.

There are many font packs based on monospace fonts, for example ttf-hack-nerd

It wasn’t like that before, and now this behavior breaks a lot of existing configurations.

Moreover, other applications like Alacritty still work. If I’m not wrong, also GTK applications are able to revert to other fonts for nerd glyphs.

@lorebett Interesting. Thanks for sharing. I’ll have to look into this further. Because of what you share, I discovered that the FiraMono Nerd Font that I have installed is from a Git pull, which Nerd Fonts state aren’t patched (they may have been at one time). However, the Agave Nerd Font was a patched zip file that I switched to about a month ago.

When I get back to my computer, I’ll have to check Kate because I had that app manually set to FiraMono as well.