KDE partially starts and then fails after recent update

I apologize for any terseness, I am posting this laboriously from my phone.

After a recent eos-update, I have been unable to start KDE Plasma properly, even though SDDM seems to work fine. The root cause seems to be that Plasma somehow can no longer find the default theme (yes I am using the Endeavour default): https://files.catbox.moe/0qebr2.jpeg

This leads to what looks like a cascade of failures of a few other services: https://files.catbox.moe/j31x67.jpeg

The exact symptom is that the desktop seems to partially load, including Night Color (at my custom color temperature), the Breeze mouse cursor, and any windows that I left open during my last user session, such as Firefox and KeepassXC. But it seems to get stuck after that, failing to load the wallpaper, panels, desktop icons, etc. And none of the Plasma keyboard shortcuts work. https://files.catbox.moe/5vfcln.jpeg

The failure seems isolated to my own user account. I created a fresh user account and was able to log into KDE Plasma without any problems.

I have tried deleting all of $XDG_CACHE_HOME and rebooting, following a suggestion in another thread that there might be a bad cache entry somewhere from an old version of the program. however that did not solve the problem.

I have run eos-update many more times since the problem began and the outcome is always the same.

I have also tried searching for these error messages and have never been able to find anything useful. I hope that someone is able to help me solve this.

This means there is something broken in your config. In that case, it probably wasn’t a result of an update. Updates shouldn’t touch stuff in your home directory.

The path to solution here is clear: you can either identify which config breaks stuff, or you can revert Plasma to defaults (by copying the config from the other user).

Reset your plasma install:

## Backup existing configs:
cd ~/.config
mkdir plasma-bak
mv *rc plasma-bak/
mv kdeglobals plasma-bak/


This removes all theme changes and widgets.

This is from memory - I am at work :smiley:

1 Like

Indeed, that’s what I ended up doing. I ultimately had to remove everything in my config directory before I noticed that I had a corrupted XDG_DATA_DIRS environment variable in a long-forgotten corner of my system configuration, pointing to some Flatpak-related directories.

It seems like somehow my KDE configuration had possibly even been stashed inside one of those Flatpak directories, because my Night Color configuration persisted even after rm -rf ~/.config ~/.local/share ~/.cache ~/.state.

The error message about being unable to find the “default” theme was the main clue, because it listed several directories that did not look like system default directories. For future reference, env vars used by KDE are documented here: https://userbase.kde.org/KDE_System_Administration/Environment_Variables#XDG_DATA_DIRS.

As general advice to potential future readers, if something looks like it’s searching in a weird place for themes or other data, consult the above document to make sure that environment variables are configured as expected.

The problem was ultimately that a wayward environment variable was pointing to the wrong place. Removing my KDE config didn’t address the problem at all in this particular case.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.