Kde limited connection but internet works

Hello, today I bought a new modem and as soon as I connected Kde tells me “limited connection” (Kde tells me that the internet doesn’t work but it actually works)

I already tried these two things:

cat /etc/NetworkManager/conf.d/20-connectivity.conf



cat /usr/lib/NetworkManager/conf.d/20-connectivity.conf


The interesting thing is that from the modem settings I assigned a static IP address to the device… and the problem was solved. So the problem is the dynamic IP address. How could I solve?


How many devices are connected to your modem?

And isn’t your problem is solved by applying a static IP?

Hi, three devices are connected: Smartphone, Windows PC and Linux PC. With Smartphone and Windows I don’t get any similar message.

As for the static IP, the message is resolved by adding the Linux PC with the static IP. But it’s strange, with the old modem I didn’t have a static IP and the message wasn’t there

I had this happen on another distro with KDE for a bit. I can’t remember what caused it exactly, but it was solved with an network manager package update.

I also had this in my XFCE setup but it got fixed after a couple of updates. I don’t know what causes it though.

@s4ndm4n @brucehankins
I’ll try waiting for the updates, the connection works so it’s not a big problem. In my case, however, I doubt it is a question of updates because if I put the old modem back, the problem doesn’t exist

Might be a DNS resolve issue or the IP issued to your device by DHCP is replicated on another device. Which is cached in the modem.

I don’t think there are other devices connected to the same IP address, at least in the modem configuration they all seem to be connected to different IP addresses (photo)

I also have an access point, but it is set to

It’s possible it’s a DNS issue but I don’t know where to get my hands on the modem settings honestly

It’s really strange. When this same thing happened to me I was unable to find what was causing it.

Well… as long as I don’t see any strangeness in the connection, the problem interests me relatively. It’s definitely annoying but if it’s a false alarm I can ignore it

I tried to start Kde Neon from live and the connection doesn’t give me the same problem… it’s really strange

Totally randomly the problem no longer occurs :person_shrugging:

I’ll see if it comes back over time

I withdraw the comment, the problem is back again

1 Like