KDE/Dolphin copy-paste error on mounted NTFS drive

Hello, I have a problem with cut&paste in Dolphin.

I have mounted NTFS drive via
UUID=%UID% /mnt/data ntfs defaults,nls=utf8,umask=000,dmask=027,fmask=137,uid=1000,gid=1000,windows_names 0 0
but when I try to copy-paste stuff with Dolphin, the files disapper from source location and do not seem to appear in target location.
After some looking around I have noticed the files do appear in the target (not visible in file manager, can be seen in terminal using ls) but are not accessible:

ls: cannot access 'img1.jpg': Input/output error
ls: cannot access 'img2.jpg': Input/output error
ls: cannot access 'img3.jpg': Input/output error
img1.jpg  img2.jpg  img3.jpg

I cannot remove with even with sudo rm img1.jpg. Is it possible to recover them?

Am I mounting NTFS drive wrong in some way or what the problem could be?
Copying works fine and there doesn’t seem to appear on ext4 drive.

What does ls -l show for those files?

Also, what is the output of findmnt --real

try changing the fmask value ie. 117
fmask is for setting the file permissions
dmask is for directories
umask does both

edit: forgot to say reboot after the fstab modification

After setting fmast to 117 cut-paste seems to be fixed but the files are still in error’d state.

$ls -l
ls: cannot access 'img1.jpg': Input/output error
ls: cannot access 'img2.jpg': Input/output error
ls: cannot access 'img3.jpg': Input/output error
total 1288
-????????? ? ?       ?            ?            ? img1.jpg
-????????? ? ?       ?            ?            ? img2.jpg
-????????? ? ?       ?            ?            ? img3.jpg

Same for sudo.

findmnt --real reports /mnt/data /dev/sdb4 fuseblk rw,nosuid,nodev,relatime,user_id=0,group_id=0,default_permissions,allow_other,blksize=4096

This seems odd.

Shouldn’t you be using ntfs3 here?

I have an external ntfs drive and I just use:

If your adamant on setting file permissions this may help

1 Like

Is your system up-to-date?

There was a recent issue (malfunction) with util-linux and util-linux-libs which has been solved by an update.

Either changing fmask to 117 or changing options to defaults,noatime fixes the issue.
I have fully updated system as of writing this message.

Is is possible to fix or remove the error’d files?

Currently trying to remove them fails:

$sudo rm img1.jpg
rm: cannot remove 'img1.jpg': Input/output error

Safely unplugged the ntfs-drive before? Rebooted your Linux?

Yes, I have rebooted. Drive is internal so I don’t unplug it.

Did you run a chkdsk -f from within Windows? - It might be advisable.

I do not have Windows installation available. Is there no way to do anything aside from finding windows to run check?

Not that I know of. It is why I keep an image of Windows 7 in Virtualbox.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.