KDE Doesn't Pick Up Colorschemes yet There Present in the Settings

I’m having a really weird issue where if I install a global theme it installs everything correctly, and when I apply it applies everything, but once I go into my color schemes tab it says “color scheme is not installed, selecting default one instead”


Normally it works fine but with some apps, it will default to breeze light and it hurts my eyes so bad. Are there any fixes?

Which colorschemes are you having trouble with?

Any downloaded within a Global Theme. It installs the respective color scheme but for some reason, it doesn’t connect that color scheme to its global theme? It’s a strange bug.

Can you check where they installed to? They should be under home/.local/share/color-schemes

Delete that color scheme. click on get new color schemes. download and install it again.

That big copper colored warning means something.If your internet is not that great when installing a global themes from settings things can go wrong.

2 Likes

Also if you continue to get errors installing this way you can go to kde-look and download and install them manually or with ocs-url

It’s with every single global theme I try and download. I genuinely have no idea, but if downloading it manually fixes it I’ll do that. Is there anything I can do to fix it?

Yep they seem to be there.

Have a go doing it manually and see if it works, I don’t normally download themes through the settings as I have had annoying errors this way before also by doing it manually you know where the files are

So I just installed 2 random global themes and don’t have this issue at all. I know you said it is happening with all you have tried - out of curiosity which themes are these? Another thing I dont think anyone has suggested is to try a reboot (although you shouldn’t need to) and see if this helps

It is always best to log out and then back in on KDE when you make these kind of changes.

Any DE in general too

Issue seems to be with the ambient-blue theme. I just tried it, however i am able to set the color scheme on its own. I will have a better look at it soon.
The error is in the global theme, in the defaults file it is looking for Ambient-Blue where as the file is AmbientBlue

If you change the line to this it will work setting as a global theme
ColorScheme=AmbientBlue

Link to a working theme