Kde connect doesnt work

kde connect never shows devices to connect what should i do ?

Hi, Giftedkid0!
Try to open the necessary kdeconnect ports in firewalld if your default zone is “public”:

sudo firewall-cmd --permanent --zone=public --add-service=kdeconnect
sudo firewall-cmd --reload

On my system I changed in firewalld default zone to “home” and enable kdeconnect service in settings.


it worked my phone does connect but now it frequently disconnects and when i refresh from the kde settings it gets connected again how do i fix this now?

Maybe some kdeconnect permissions on your phone like “pause app activity if unused” or anything else is cause of this issue.

yeah i configured it to unrestricted battery since then it works like charm

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.