KDE Connect Can't find my Device

Decided to read this wiki to figure it out:

sudo netstat -tunelp | grep -i kdeconnect
[sudo] password for zpero:
tcp6 0 0 :::1716 :::* LISTEN 1000 14266 1557/kdeconnectd
udp 0 0* 1000 14267 1557/kdeconnectd
udp 0 0* 1000 279309 1557/kdeconnectd
udp6 0 0 :::5353 :::* 1000 14268 1557/kdeconnectd
udp6 0 0 :::47191 :::* 1000 279310 1557/kdeconnectd
udp6 0 0 :::47193 :::* 1000 279311 1557/kdeconnectd
udp6 0 0 :::39822 :::* 1000 279312 1557/kdeconnectd
udp6 0 0 :::1716 :::* 1000 14265 1557/kdeconnectd


netcat -z -v 1714-1764
(This takes over 2 minutes to do anything and fails to return anything at all when the command finally runs)

I ran these commands:

sudo firewall-cmd --permanent --zone=public --add-service=kdeconnect
sudo firewall-cmd --reload

They both said “success”

Devices still cannot find each other.
How do I get this to work?

I can transfer files between the two devices with bluetooth, but I don’t want to use Bluetooth I want to use WiFi. Here is some other data that might be helpful:

Plasma 6.0.1
Shell: zsh 5.9
Kernel: 6.7.9-arch1-1
My phone is a Pixel 8 Pro running GrapheneOS.

Thanks in advance.

First try turning off the firewall just to see if it works, if it does then we know it is a firewall problem. We can then turn it back on and try and figure it out from there.

I disabled it with systemctl and confirmed it was inactive. After this, I opened the settings menu and went to the KDE Connect section. Clicked refresh, still not finding my phone. Phone still not finding PC.

netcat -z -v xxx.xxx.x.xxx 1714-1764

This command still takes over two minutes to run and returns absolutely nothing.
What’s the next step?

If it can’t find it even without the firewall, then there is an option to manually add the device by it’s ip address. Try that.

It is the firewall causing the problem. See here for more info and the correct ports to open to allow the phone to be seen. Or as @d-air1b said, you could just disable it (I realize you didn’t necessarily mean to disable it permanently, rather for testing purposes).

Where is this option? I cannot find it.

Nope. I turned it off, and it still doesn’t work.

Open the kdeconnect app on your phone and click the hamburger menu. Then click settings. From there look for add devices by ip.

1 Like

Can you ping your phone from the computer?

Are you connected to a VPN on your phone?

1 Like

This was actually the solution. I was connected to a VPN with “always-on VPN” and “Block connections without a VPN” also turned on. I disabled them, and I was able to find and connect to my PC.
I also tried re-enabling the firewall, and it still works, probably thanks to those commands from the wiki.

1 Like

Brilliant! I had the same problem previously.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.