Kde cant change refresh rate

I am using kde wayland, not sure from when, it does not allow me to change the refresh rate any more, now it is set to be 120hz, it used to allow me to choose between 30, 60, 120. Any idea why and how to fix if it is an error?

System info:
Up to date EndeavourOS
CPU: AMD Ryzen 9 6900HS with Radeon Graphics (16)
GPU: AMD ATI Radeon 680M
GPU: AMD ATI Radeon RX 6800S

EDIT: changed back to Xorg just now to test, it also doesn’t allow changing the refresh rate.

I have a high refresh laptop, and I use Kde daily, I’ve tested on both X11 and Wayland and I can switch to 60hz without problem.
I lack data to confirm if you use a laptop or not, but from the specifications I infer that it probably is.
For this reason, I recommend that you find out if your device has a MUX switch, because if it is activated in Ultimate instead of Optimus it can cause problems in the behavior of the device.

PS: Another reason why I think this may be the problem is because it doesn’t allow you to change the resolution either.

What is the hardware?

I am using a laptop ROG Zephyrus G14 (2022) GA402RK, I guess it has MUX switch? I will have a check

EDIT: Just went to windows and checked: has Ultimate, Standard, Eco Mode and Optimised. And it is set to Standard.

ROG Zephyrus G14 (2022) GA402RK

1 Like

Ok, I also have an Asus.
I recommend installing asusctl and rog-control-center from the AUR. From there you can control everything that may interest you, including the MUX switch.

1 Like

Oh, I have those two packages :slight_smile: I will have a try now

Perfect!, remember to update because not long ago they enabled the option to modify the MUX switch, it is where I point in the screenshot

1 Like

Change to the latest stock kernel (6.1.8-arch1-1) solve the problem :slight_smile: (previously I am using the g14 customised kernel)

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.