Kate segfaults with new EOS ISO

So, this is funny

On my main machine, where I’ve installed EndeavourOS with the 21.5 ISO, everything is working fine. So I want to reinstall Endeavour, for various reasons, and started with reinstalling it on my laptop first, so that I don’t throw away my main system the way it is right now.

So I install EndeavourOS with the 22.0 ISO on my laptop, configure only the KDE stuff that comes pre-installed, aaand … Kate crashes when I try to configure it. I open Kate through the terminal, try to see what happens, and everything appears completely normal. The instant I click “configure Kate” in the settings menu, I see “segmentation fault”, and nothing else. Reinstalling with the 22.1 ISO doesn’t do anything to that either.

I’ve seen this on two completely different machines now. Please advise / fix.

Could you paste the (full) output (as text) so other people can see too?

You’re aware that noone on this forum maintains or develops KDE, right? :stuck_out_tongue_winking_eye:

5 Likes

I am running Kate 22.04.1, which should be the latest version of Kate from the Arch stable repos at the time of this post.

I’m unable to reproduce your issue.

2 Likes

Could you paste the (full) output (as text) so other people can see too?

Will do, give me a few hours.

You’re aware that noone on this forum maintains or develops KDE, right?

I’ve thus far seen this issue exclusively after installing a system with the EndeavourOS 22.x ISOs. I can’t see this issue when running this on my main system that I’ve installed with the EndeavourOS 21.5 ISO, and I can’t see this issue on Manjaro either. So I don’t think this is (directly) a Kate issue, I’m pretty sure this is specifically an EndeavourOS issue.

EndeavourOS ISOs do not contain Kate. When you do an online install, Kate, among other stuff, gets downloaded from the Arch repos.

It’s the same version of Kate I have.

1 Like

I’m aware of that, and that makes it frankly even more confusing to me.

But if it is not the ISO that is the issue, then what is the issue, since I am seeing this as a consistent & repeatable problem?

And that’s the sample of 1 user with this issue, so far…

We need more info to help you.

1 Like

Until we see what is actually happening with some logs none of us can answer that we can only guess what the problem may be. And since we are unable to reproduce it even guessing is hard.

1 Like

Before trying anything else, make sure your system is not partially updated: do a full update (with sudo pacman -Syu).

Slightly different question: What kind of logs should I send you?

If I just send you what I’m seeing from the terminal after starting Kate like that, the only thing that I see there that is out of the ordinary is “segmentation fault” without anything leading up to it. That is if I only run kate without any flags. Are there any other kind of logs or are there any flags I should use to give more information?

https://wiki.archlinux.org/title/Core_dump
https://wiki.archlinux.org/title/Journalctl

3 Likes

I doubt this very much. This is an issue exclusively on one of your machines. I also use KDE and never had any segfaults with anything. Have you changed settings in regards to application style or fonts?

Start from terminal with

kate --new-session

Or create a new user and try with that one.

I have created a gist on GitHub that includes every single log that I can get with the EndeavourOS log tool. Nice that I managed to stumble across that one.
https://gist.github.com/ThursdayTG/41db0f97d5ae12433095eb4ae4857504

A few things I want to clarify:

  • This is not exclusively on this one machine, I have seen this happen just today on computers of my school as well, which have very different hardware than my laptop.
  • This has nothing to do with partial updates or edited settings, because I’m seeing this on reinstalls without changing or installing anything at all. When I’ve created the logs, I did nothing but change the theme to Breeze Dark and set KDE to only select files on click, rather than opening / executing them.
  • Also an update on my statement regarding Manjaro: Turns out I can find the same mysterious segfault problem there as well, so yeah, I can’t say that this is an Endeavour-specific issue anymore.
1 Like

So perhaps the best place to report the issue for it to get fixed would be:

https://bugs.kde.org/

https://community.kde.org/Get_Involved/Issue_Reporting

1 Like

Makes sense, I’ll do that, then

1 Like

Well i find this odd as i don’t see this problem on mine and i have multiple systems loaded with KDE both EOS , Arch and Manjaro. :shushing_face:

1 Like

kate was crashing for me when I tried opening its settings, I changed to kwrite.

1 Like

Was wondering if you get this error if you login with another user?
As I have found a few similar topics (although old) where resetting the plasma configs solved the problem. Here is some information from the Arch Wiki
https://wiki.archlinux.org/title/KDE#Configuration_related

1 Like

On my main system, where I’ve done a lot of things, I have absolutely no issues with Kate. On my laptop, however, I have these issues after a complete fresh install without changing or installing anything at all whatsoever.