Kate - can't save system files

Ok, so I try to edit some system files. No problem with opening and editing. But when I try to save the edited file, Kate tells me that this action requires root privileges. So I type in my root password but Kate acts like the password is wrong. I tried a few times, doesn’t work. Is this a bug? Do I miss something here? Do I maybe need a plugin or anything for this to work?

It wants you user password, not the root password.

1 Like

I’d recommend using sudo nano for editing system files directly.

Nope. It explicitly asks for root privileges. I even tried the user password.

If you are referring to this box, it is expecting your user password.



Ok, I will try again. But why does it state “Root” if it wants the user password? A bit confusing, isn’t it?

edit Yep, you’re right! Thx for the quick help!

Think of it like sudo. You type your user password when you want to elevate privileges for your user.

Yeah, but still a bit confusing. Shouldn’t both passwords work then?

No. It’s exactly like sudo. Root password won’t work with sudo either. You use the root password only when you want to log in as root (which is very rare). In every case except that, you use your user’s password.

In fact, it would be very stupid if you needed to use the root password with sudo. Then the sysadmin would have to give the root password to every user who is allowed privilege elevation, which would be really unsafe.

Of course, Kate uses polkit, not sudo, but it’s very similar.

Well, yeah, still a bit confusing. Earlier today I downloaded all the EOS wallpapers via the welcome app and this also asked for root (which kinda surprised me to be honest) and here the root password worked.
Maybe I should just make root my default account :wink:

edit Dolphin root actions also require root password.

This is a setting for EndeavourOS (can’t recall exactly where it is a the moment - but will check and get back) - can be configured YOUR way if desired. At least it is clear as to which it wants! Watch for the edit…

Edit: The file is etc/eos-script-lib-yad.conf and the section is EOS_ROOTER. Here is a look at that section in mine…

EOS_ROOTER section
## EOS_ROOTER configures the command for acquiring elevated privileges
## when running commands in terminal.
## Supported values:
##   "su"
##   "sudo"
##   "pkexec"
##   "su-c_wrapper"
## Still supported values, but deprecated and will be removed in the future:
##   "su -c"
##   "pkexec bash -c"
##   "sudo bash -c"
##   "/usr/bin/su -c"
##   "/usr/bin/pkexec bash -c"
##   "/usr/bin/sudo bash -c"
export EOS_ROOTER="su"

If you wish consistency across everything, you could set it to ‘sudo’ - I leave some things as one, some the other in an effort to make myself think about what I’m trying to do!

1 Like

It is saying it needs root privileges, and one way to get root privileges is to escalate permissions through the use of a tool like PolicyKit or sudo.

1 Like

Interesting, thank you! And I have to say that I really like this tool, it’s really handy to have something like this especially for new users.

Yes, I understand. But I think that there could be better distinction. When the system asks me for a password it should be clear which one it wants.
Also I wonder who decides which password is needed? Is the something the dev/coder can choose? If so, I really don’t understand why one KDE app (Dolphin) needs the root password while another KDE app (Kate) wants the user password.


Because the “rootactions” isn’t part of dolphin. It is a 3rd party add-on.

Also, rootactions tries to use you user password before falling back to the root password. However, since it hasn’t ben updated in many years, the tool it tries to use to do that no longer exists.


Thx for the explanation! And yeah, ofc you are right, Root Actions is 3rd party. I should have known this 'cause I just installed it 2 days ago. Got used to this on Manjaro and was missing it on EOS right from the start 'cause the trash bin on KDE just sucks, especially with USB drives and/or larger files.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.