JetBrains mono font not working properly inside terminal

hey guys, this is my first experience with arch and endeavour, so far its great!
I wanted to install jetbrains mono as my font so that I can use it inside terminal and nvim specially. I have installed the fonts via fc-cache and have chosen it as my preference in the terminal emulator settings. and even though the sample that shows when selecting your font on the settings works properly. the font doesn’t work properly inside the terminal.

I tried installing another version from nerd-fonts (jetbrains mono Nerd)
which was the one I had on my previous system, and even though it gets recognized by other gui applications like the text-editor, it doesn’t get recognized by the terminal emulator settings

what could be causing this, I’d appreciate any help.

Thanks in advance.

Which terminal?

xfce terminal, the one that comes with the default installation of endeavour

This is plasma, just installed xfce4-terminal:

How did you install the font?

at first I tried putting them all in ~/.local/share/fonts/ and running fc-cache -f -v
after that didn’t work I tried this package

but still my things don’t work, for example === doesn’t become a triple vertical line.

They are in the repo:

 1 community/ttf-jetbrains-mono 2.304-1 [0B 7.44MiB] [Installed]
    Typeface for developers, by JetBrains
 2 community/ttf-jetbrains-mono-nerd 2.3.3-2 [0B 137.96MiB] [Installed]
    Patched font JetBrains Mono from nerd fonts library


sudo pacman -S ttf-jetbrains-mono  ttf-jetbrains-mono-nerd 

May need --overwrite='*' on the end if it complains about stuff existing in file system.

still the same issue, I have applied it but as you can see even though its fine in the settings, its not applied to the terminal (or neovim for that matter)

What does:

cat ~/.config/xfce4/terminal/terminalrc | grep FontName


FontName=JetBrainsMono Nerd Font Mono Medium 16

So it is in the config file - if you increase the font size in the settings - does it increase in terminal? Other than that no idea, sorry.

yes it does, but the effects are still not applying :frowning:

So what are you expecting to happen?

the font is supposed to change many things like this, but its not happening.

as you see it works on the gui editor

Terminals based on libvte do not support ligatures. There is a good list of supported terminals and editors at

Try a different terminal - appears xfce = no ligatures

oof, I didn’t know that. thanks a lot!

I use kitty, the dev can be a bit of an ****, but it supports a lot of stuff, including:

oof thats cool, i’m gonna give it a try, thank you

That is ranger file manager:

# * kitty:
#   Preview images in full color using kitty image protocol.
#   If ranger does not share the local filesystem with kitty
set preview_images_method kitty

In config file.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.