Jellyfin Permission Problem

Hi there
I want to set up my media server as I did it in windows using Jellyfin.
So I’m using jellyfin AUR to install it.
Some problem with service occur, and I’m successfully managed it with jellyfin.service and some systmctl command.
But now when I want to configure library it just shows folder in "/ " and /home/$user directory.
I think it’s necessary to mention i have some NTFS drive and an ex4(to extend home) and all of them set up mount point with fstab.
my fstab:

# /etc/fstab: static file system information.
# Use 'blkid' to print the universally unique identifier for a device; this may
# be used with UUID= as a more robust way to name devices that works even if
# disks are added and removed. See fstab(5).
# <file system>             <mount point>  <type>  <options>  <dump>  <pass>
UUID=Censored                            /boot/efi      vfat    defaults,noatime 0 2
UUID=Censored   /              ext4    defaults,noatime 0 1
UUID=Censored   /home/$USER/Mount/LinuxExtend  ext4    defaults,noatime 0 0
UUID=Censored   /home/$USER/Mount/H  ntfs-3g    defaults,noatime 0 0
UUID=Censored   /home/$USER/Mount/F  ntfs-3g    defaults,noatime 0 0
UUID=Censored   /home/$USER/Mount/E  ntfs-3g    defaults,noatime 0 0
UUID=Censored   /home/$USER/Mount/G  ntfs-3g    defaults,noatime 0 0
UUID=Censored    /home/$USER/Mount/C  ntfs-3g    defaults,noatime 0 0

trying with:

chmod -R 775 /home/$USER/Mount

But doesn’t help

 ls -al /home/$USER/Mount

retuned :

drwxrwxr-x  8 $USER $USER  4096 May 12 21:47 .
drwx------ 29 $USER $USER  4096 May 18 14:39 ..
drwxrwxrwx  1 root   root   12288 May 10 11:37 C
drwxrwxrwx  1 root   root   28672 May 10 11:37 E
drwxrwxrwx  1 root   root   65536 May 12 15:21 F
drwxrwxrwx  1 root   root   16384 May 10 11:37 G
drwxrwxrwx  1 root   root   12288 May 10 11:37 H
drwxrwxr-x  5 $USER root    4096 May 12 10:57 LinuxExtend

and one more thing
I noticed that jellyfin make a new user group “jellyfin” and a user which is “jellyfin”.
Would you some help?

Welcome to the forum someone will be along shortly with an answer.

1 Like

ntfs mounts need to have their permissions set at mount time. You aren’t setting any here.

Read this for the correct way to do that.

That is because ntfs doesn’t support POSIX(linux-style) permissions without a bunch of special handling. That means chmod, chown and friends won’t work.

1 Like

Thank you for your response.
Can I add multiple uid=userid,gid=groupid for each drive I mount?
Because my user in $USER groupid and the jellyfin in the jellyfin groupid


Does jellyfin need read/write or just read?

1 Like

I think it’s better If possible to give him read/write, but read only should be enough.

Then just set the permissions to be owned by your user and make the files world readable with umask=0022

Better yet, you could use dmask/fmask instead, like this: dmask=0022,fmask=0133

1 Like

So another problem came up.
When I want to choose a directory to add them to jellyfin library it shows root folder like etc., var ,mnt , home …. But when I choose /home then /$USER doesn’t show directory I have in /home/$USER like mount, downloads, document …

That is because your home is only visible by your user account, not the jellyfin user.

You could add the jellyfin to the group that is the same as your username although that would give it access to most of what is in your home directory which you may or may not want that user to have.

1 Like

before I open this topic I used chown and make /home directory my own
so now i just run:

chmod 775 /home/$USER

and problem solved for now.
thank you for your time dear dalto

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.