Jdownloader - exec: java: cannot execute: Is a directory


since a few days I cannot start jdownloader anymore.
Shell says:

[user JDownloader scope]
[user JDownloader scope]
/usr/bin/jdownloader: line 9: exec: java: cannot execute: Is a directory

I have reinstalled jdownloader2, but problem persists. Any idea?

Recently I had to install some additional java packages, but meanwhile removed them. Maybe it is connected wit that…

How did you install it?
Which Java version are you using?
Post the output of

archlinux-java status

What’s the output of

yay - Qs java

Installed via yay long time ago. So far worked w/o any problems until a few days ago.

$ archlinux-java status
Available Java environments:
No Java environment set as default

$ yay - Qs java
(nothing happens)

In your place I’d (re)install the three packages jdk-openjdk, jre-openjdk and java-openjfx.
After that is done set your default java environment executing
archlinux-java set java-14-openjdk
as root.

This means that obviously no java package/environment is installed.

Thank you. Installing the 3 packages solved the problem already. Not required to execute archlinux-java set java-14-openjdk