Jami-qt and bleachbit issues

Jami-qt hasen’t worked for me in awhile now . It installs normal from Community repo ,but all I get is icon on system tray . There I’m not able to do anything . Right clicking on icon gives selection of show jami and quit , but neither work . I have to use ksysguard to force close .
I did a fresh install yesterday (KDE) , but still same results . Is there a fix ?

Bleachbit installs and works , only issue is it closes immediatly after running scan . Removed checkmark in preferences ( exit after cleaning ), no change . Not a deal breaker but is annoying .

Really hoping to get Jami working again ! Thanks …

Launch the application from the terminal and see what error messages it returns.

Here’s the report through terminal:

[northernfrog@northernfrog-oryxpro ~]$ jami
“notify server name: Plasma, vendor: KDE, version: 5.26.4, spec: 1.2”

GL Type: desktop
Surface Type: OpenGL
Surface Profile: CompatibilityProfile
Surface Version: 4.6
QSG RHI Backend: OpenGL
Using Supported QSG Backend: yes
Using Software Dynamic GL: no
Using Multithreaded OpenGL: yes

Init Parameters:

  • application-name Jami
  • browser-subprocess-path /usr/lib/qt6/QtWebEngineProcess
  • create-default-gl-context
  • disable-features ConsolidatedMovementXY,InstalledApp,BackgroundFetch,WebOTP,WebPayments,WebUSB,PictureInPicture
  • disable-setuid-sandbox
  • disable-speech-api
  • enable-features NetworkServiceInProcess,TracingServiceInProcess
  • enable-threaded-compositing
  • in-process-gpu
  • use-gl desktop

“Using locale: en_CA”
11:33:23.304 os_core_unix.c !pjlib 2.11 for POSIX initialized
Daemon is running
No accounts to migrate
Screen saver dbus interface: “org.freedesktop.ScreenSaver”
Can’t update current account info data for “”
QQmlApplicationEngine failed to load component
qrc:/src/app/MainApplicationWindow.qml:108:5: Type DaemonReconnectPopup unavailable
qrc:/src/app/commoncomponents/DaemonReconnectPopup.qml:26:1: Type BaseModalDialog unavailable
qrc:/src/app/commoncomponents/BaseModalDialog.qml:109:5: Type DropShadow unavailable
qrc:/qt-project.org/imports/Qt5Compat/GraphicalEffects/DropShadow.qml:6:1: Cannot load library /usr/lib/qt6/qml/Qt5Compat/GraphicalEffects/private/libqtgraphicaleffectsprivateplugin.so: (libQt6ShaderTools.so.6: cannot open shared object file: No such file or directory)
Main window loaded using OpenGLRhi
NetworkManager client initialized, version: 1.40.8 , daemon running: yes , networking enabled: yes
primary network connection: ca1e2a82-2b4c-30cf-9f7d-1b750a0a0321 default: yes

Still lost on solution to fix . I’m i the only one having this problem?

Check whether the package qt6-shadertools is installed on your system.

pacman -Qi qt6-shadertools

And please reply to my comment so that I will get a notification.

1 Like

If you want notifications on a topic, you can change it to “Watching”

1 Like


Hi , anthony93 . Thank you , working now !
I ran this command (pacman -Qi qt6-shadertools ) and recieved error (error: package ‘qt6-shadertools’ was not found ) . Ran this command ( yay -s qt6-shadertools ) found and installed . Now all working !
Not sure why it wasen’t installed while installing Jami-qt + deamon . .
Anyway all working now and thank you for help . HAPPY HOLIDAY’S

If qt6-shadertools isn’t installed, then that’s exactly what you need to do to fix it.

Since jami-qt needs the package and it wasn’t included in its dependency list (that’s why it wasn’t installed when you installed jami), you need to notify the developer of jami-qt to include that dependency.

Also, please “mark as solution” to make it easier for other users to refer to this post.

Cheers, and happy holidays.

qt6-shadertools is referenced in a jami-qt bug report from October. It is currently an optional dependency, and as no one else has commented, it is still considered optional.


Thanks for the info . I only searched this forum . Will do a wider search next time . Moonfrog out !

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.