It takes a long time to establish a WiFi connection [Video added]

Before installing EndeavourOS I was distrohopping a lot. I have used Debian, Ubuntu, openSUSE, Mint & many more. Under all these distro network manager was able connect to WiFi router almost instantly. When I booted my PC I saw the WiFi was already connected & if for any reason if I disconnected my WiFi connection & reconnected the connection was instant. I didn’t time it but it used to be within 1-2 secs max.

Now under EndeavourOS when I boot my PC I see network manager spinning & spinning for like 10-15 secs & then it finally connects. The same thing happens it I manually disconnect & reconnect.

I didn’t create a topic about this problem coz I thought this nothing serious but since I have to deal with this everyday it becoming really annoying.

Is there a way to find out why this is happening ?

Note : I am using the hardened kernel now but the same thing was happening with the regular kernel so the the hardened kernel is definitely not the culprit.

$ inxi -N
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet driver: N/A 
           Device-2: Realtek RTL8188EUS 802.11n Wireless Network Adapter type: USB 
           driver: r8188eu 

Please watch this video & you will understand the issue easily

Have you tried installing and booting the LTS kernel? I am no expert on wifi or networks so beyond this I have no suggestions. I have had a few instability problems recently with kernels which leads me to suggest this. It’s not a fix but it might be worth checking. :man_shrugging:

Yes, I have tried all three kernels namely LTS, mainline & hardened but the WiFi connection time was the same. Its definitely not the kernel which is causing this.

Hmm interesting. I sit here now using a desktop EnOS install without issues and a standard Network Manager. Do you have another machine you can use to check your wifi?

I’ve experienced similar on a couple of my laptops. A change which made a big difference for me was replacing the standard NetworkManager installation which uses wpa_supplicant with a configuration which uses iwd as the backend, instead. Basically, install the networkmanager-iwd package from AUR.

Unfortunately I don’t have that liberty. I am the only person in my home who uses a computer so I never bothered to buy another desktop/laptop.

1 Like

I was not aware that something like iwd exists I searched an found that iwd is next gen tech. I will definitely consider this fix but I am a bit worried. If by any I chance lose connectivity after replacing wpa_supplicant with the iwd backend it is going to be a major headache coz then I wont be able access even this forum.

I will wait patiently and see what others say & act carefully.

Are you running in a VM? You may find that in doing so you might not download/install the drivers that are needed.

You are asking if I am running if I am running EndeavourOS in a VM ? No, I am running on actual hardware. I don’t have any virtualization software like Virtualbox installed & no VMs whatsoever.

OK just checking! :grin:

Network adapter type: USB 8188eu. Can you change this? On a laptop I suppose not but maybe through software, I don’t know. Perhaps someone who is awake can help?

Buy a new USB WiFi dongle ? Its doable but fact is as said I didn’t notice any delay in connectivity using this USB WiFi dongle with other distros.

Yes, let’s wait and see if someone can solve this.

1 Like

@wordler @jruschme

This is the problem >>>

So does this mean the problem is not wifi at all or just not connecting with Mega? Is connecting with Mega just slowing down your connection?

No, I noticed this delay just right after a fresh install of EndeavourOS when no user installed apps like Mega was installed. I was just lazy & didn’t do anything about it. Under Debian & its derivatives like Ubuntu the time it took to establish the WiFi connection was less than even half in comparison.

That’s weird. Endeavour is just an Arch install with some other repos to make life easier plus a great community. I would wonder whether the Arch install of this has issues?

Yes, my guess too is that the Arch base is responsible for this. Just in case nobody here manages to offer a solution or workaround I will try hard to find a solution on IRC. I cant post on the Arch forums coz afaik they don’t support derivatives.

1 Like

Totally agree. Arch is seen as bleeding edge but sometimes that isn’t the truth. I trust them but if you want the the most up to date perhaps not. If you really want your own then build your own.

1 Like

I suspect that at least some of the issue is in the Arch base config for NetworkManager. One thing that I noticed is that my WiFi speeds improved greatly when I changed the MacId randomization settings for WiFi from “random” to “stable”. (See the archwiki entry for NetworkManager for details.)

what services have you got running after boot up:

systemd-analyze blame