Issues with X and wayland

I have been using endeavor for a month or so. I have two separate set of issues which are rendering the system unusable and causing frustration.

My main choice at the moment is X, it works fine I just have one issue with it. Every time I leave my laptop for few minutes and system is allowed to sleep. When it wakes up it is frozen on login screen and not even password prompt is shown. I have left it for about an hour and it doesn’t get unstuck.

Due to above issue I switched to wayland and it have different kind of issues. But the wakeup thing is fixed with wayland.

With wayland the laptop freezes randomly even it is idle. I had the same issue on Manjaro as well so I guess it is a common wayland problem.

Wayland refuses to play videos with mplayer among other things. But hey, its still work in progress so understandable.

I would really appreciate any help fixing either of these. (Preferably X though)

Thank you.

I’ve experienced similar issues with sleep. It’s a workaround more than a fix, so I’m interested to see what others may share, but I’ve taken to just disabling auto sleep and hibernation entirely. I let the screen turn off, but that’s it.

Of course, may not be feasible if your’re frequently on battery and away from the system.

1 Like

Thank you @Bink.

I am afraid it won’t work for me, since I am usually on battery and this will drain it fast.

For this so far I have no idea how to even start debugging. I will surely share it here if I made some progress.

What kind of hardware and desktop environment are you running? Bios up to date to get around that amd cpu stuttering issue that was a big thing for a while and still an issue on some architectures?

Codecs installed? Do the same videos work with say vlc or mpv? I just tried to play a video with mplayer myself via the terminal and it worked fine. Video codec was AVC and audio was vorbis for the one I tested with.

1 Like

Using the LTS kernel is a simple thing to try, provided your hardware isn’t too new for it (my audio only just recently got supported by the standard kernel on my laptop).

Suspend and Hibernate > Troubleshooting

Suspend/hibernate does not work, or does not work consistently

There have been many reports about the screen going black without easily viewable errors or the ability to do anything when going into and coming back from suspend and/or hibernate. These problems have been seen on both laptops and desktops. This is not an official solution, but switching to an older kernel, especially the LTS-kernel, will probably fix this.

1 Like

@d-air1 Thank you for your suggestions.

What kind of hardware and desktop environment are you running?

  Kernel: 6.8.9-arch1-1 arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
  Desktop: KDE Plasma v: 6.0.4 Distro: EndeavourOS base: Arch Linux
  Type: Laptop System: LENOVO product: 82XT v: LOQ 15APH8
    serial: <superuser required>
  Mobo: LENOVO model: LNVNB161216 v: SDK0T76463 WIN
    serial: <superuser required> UEFI: LENOVO v: LYCN39WW date: 09/22/2023
  ID-1: BAT1 charge: 62.0 Wh (99.2%) condition: 62.5/60.0 Wh (104.1%)
    volts: 17.4 min: 15.4 model: Sunwoda L22D4PA0 status: full
  Device-1: hidpp_battery_0 model: Logitech Wireless Mouse B330/M330/M331
    charge: 55% (should be ignored) status: discharging
  Info: 8-core model: AMD Ryzen 7 7840HS w/ Radeon 780M Graphics bits: 64
    type: MT MCP arch: Zen 4 rev: 1 cache: L1: 512 KiB L2: 8 MiB L3: 16 MiB
  Speed (MHz): avg: 1650 high: 3799
    min/max: 400/5137:5449:5293:6080:5764:5608:5924 cores: 1: 3799 2: 400 3: 400
    4: 400 5: 3767 6: 400 7: 3767 8: 400 9: 3628 10: 400 11: 3679 12: 400
    13: 3768 14: 400 15: 400 16: 400 bogomips: 121416
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Device-1: NVIDIA AD107M [GeForce RTX 4050 Max-Q / Mobile] vendor: Lenovo
    driver: nvidia v: 550.78 arch: Lovelace bus-ID: 01:00.0
  Device-2: AMD Phoenix1 vendor: Lenovo driver: amdgpu v: kernel
    arch: RDNA-3 bus-ID: 05:00.0 temp: 40.0 C
  Device-3: Luxvisions Innotech Integrated Camera driver: uvcvideo type: USB
    bus-ID: 1-3:2
  Display: x11 server: X.Org v: 21.1.13 with: Xwayland v: 23.2.6 driver: X:
    loaded: amdgpu,nvidia unloaded: modesetting dri: radeonsi gpu: amdgpu
    resolution: 1920x1080~144Hz
  API: EGL v: 1.5 drivers: nvidia,radeonsi,swrast platforms:
    active: gbm,x11,surfaceless,device inactive: wayland,device-1
  API: OpenGL v: 4.6.0 compat-v: 4.5 vendor: amd mesa v: 24.0.6-arch1.2
    glx-v: 1.4 direct-render: yes renderer: AMD Radeon Graphics (radeonsi
    gfx1103_r1 LLVM 17.0.6 DRM 3.57 6.8.9-arch1-1)
  API: Vulkan v: 1.3.279 drivers: nvidia surfaces: xcb,xlib devices: 1
  Device-1: NVIDIA vendor: Lenovo driver: snd_hda_intel v: kernel
    bus-ID: 01:00.1
  Device-2: AMD ACP/ACP3X/ACP6x Audio Coprocessor driver: snd_pci_ps
    v: kernel bus-ID: 05:00.5
  Device-3: AMD Family 17h/19h HD Audio vendor: Lenovo driver: snd_hda_intel
    v: kernel bus-ID: 05:00.6
  API: ALSA v: k6.8.9-arch1-1 status: kernel-api
  Server-1: PipeWire v: 1.0.5 status: active
  Device-1: Realtek RTL8111/8168/8211/8411 PCI Express Gigabit Ethernet
    vendor: Lenovo driver: r8169 v: kernel port: 3000 bus-ID: 02:00.0
  IF: enp2s0 state: down mac: <filter>
  Device-2: Realtek RTL8852BE PCIe 802.11ax Wireless Network vendor: Lenovo
    driver: rtw89_8852be v: kernel port: 2000 bus-ID: 03:00.0
  IF: wlan0 state: up mac: <filter>
  IF-ID-1: docker0 state: down mac: <filter>
  IF-ID-2: vboxnet0 state: down mac: <filter>
  Device-1: Realtek Bluetooth Radio driver: btusb v: 0.8 type: USB
    bus-ID: 1-4:3
  Report: btmgmt ID: hci0 rfk-id: 4 state: up address: <filter> bt-v: 5.3
    lmp-v: 12
  Local Storage: total: 476.94 GiB used: 323.44 GiB (67.8%)
  ID-1: /dev/nvme0n1 vendor: KIOXIA model: N/A size: 476.94 GiB temp: 41.9 C
  ID-1: / size: 458.74 GiB used: 321.89 GiB (70.2%) fs: ext4 dev: /dev/dm-1
    mapped: luks-fc3f05ef-42bb-4eae-89ee-c9c3905bb911
  ID-1: swap-1 type: partition size: 8.78 GiB used: 1.29 GiB (14.7%)
    dev: /dev/dm-0 mapped: luks-62f8bec8-064c-4470-abf6-e4adaa4651e8
  System Temperatures: cpu: 45.8 C mobo: N/A
  Fan Speeds (rpm): N/A
  Memory: total: 24 GiB note: est. available: 22.71 GiB used: 7.5 GiB (33.0%)
  Processes: 421 Uptime: 3h 53m Init: systemd
  Packages: 1408 Compilers: clang: 17.0.6 gcc: 13.2.1 Shell: Zsh v: 5.9
    inxi: 3.3.34

Bios up to date ?

Wayland refuses to play videos with mplayer among other things
After recent update this issue seems to fixed itself. I am now able to play videos with any player. But before VLC was working fine issue was with mplayer.

@Bink Thank you for your suggestion.

I will try an older LTS kernel and see what happens. :+1:

I see you have a hybrid graphics setup. I have never run such a setup myself, but I know people tend to use software to manage that. Perhaps you might find more answers by searching for hybrid graphics stuttering on Linux.

Edit: I’ve also seen people mention stuttering related to the newest Nvidia 550 driver and they had to downgrade back to 535 while simultaneously switching to the lts kernel. I personally have not had that problem myself, but these driver bugs tend to be hit or miss anyways.

1 Like

@d-air1 Thank you for pointing that out.

I am experimenting with only enabling UMA(Integrated) graphics by setting the option in BIOS. I noticed that a few errors during boot that I use to see are now not appearing. Although my google searches directed me to ignore those. They might not be that innocent.

It could be that my both set of issues are tied to NVIDIA being NVIDIA.

I also found these bug reports