Issues with ProtonVPN CLI after updating keyring and system

I just updated keyring and system as per solution to this post. This time, flawless. I’ve installed protonvpn-cli (official) using paru but get python related errors trying to connect. This had worked fine in the past. I tried the community version as well but get unwarranted authentication errors. Any leads?

$ protonvpn-cli c
Traceback (most recent call last):
  File "/usr/lib/python3.11/importlib/metadata/", line 563, in from_name
    return next(

During handling of the above exception, another exception occurred:

Traceback (most recent call last):
  File "/usr/bin/protonvpn-cli", line 33, in <module>
    sys.exit(load_entry_point('protonvpn-cli==3.13.0', 'console_scripts', 'protonvpn-cli')())
  File "/usr/bin/protonvpn-cli", line 22, in importlib_load_entry_point
    for entry_point in distribution(dist_name).entry_points
  File "/usr/lib/python3.11/importlib/metadata/", line 981, in distribution
    return Distribution.from_name(distribution_name)
  File "/usr/lib/python3.11/importlib/metadata/", line 565, in from_name
    raise PackageNotFoundError(name)
importlib.metadata.PackageNotFoundError: No package metadata was found for protonvpn-cli
$ paru -R protonvpn-cli
$ pipenv install protonvpn-cli
$ pipenv shell
$ sudo ~/.local/share/virtualenvs/[path]/bin/protonvpn init
$ sudo ~/.local/share/virtualenvs/[path]/bin/protonvpn c

This starts a package but I fall back on the same error as that I got with paru’s community version. That could be incidental to the question at hand, but there would also be a connection. I did verify my uname/pwd.

Connecting to NL-FREE#14 via TCP…
[!] Authentication failed.
[!] Please make sure that your Username and Password is correct.

ProtonVPN uses two different sets of credentials, one for the website and official apps where the
username is most likely your e-mail, and one for connecting to the VPN servers.

You can find the OpenVPN credentials at

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.