Issues with git/openSSL

Hi, ever since I installed EndeavourOS, I’ve had trouble updating my neovim plugins. I’ve been using Packer and Lazy and both had these issues. Packer refused to update some of my plugins, not really giving a reason, while Lazy actually refuses to update all of the plugins available, but does give me (sort of helpful) error messages. This is what I see with 90% of plugins:

 fatal: unable to access '': OpenSSL/3.0.8: error:0A000438:SSL routines::tlsv1 alert internal error

Some also fail with this error:

fatal: unable to access '': Could not resolve host:

The problem that I see is that I am not able to pull many git repos at the same time. Pulling just one is fine and doesn’t give me any errors. Same thing happens when I updated only one plugin at a time. My neovim config also doesn’t give me errors anywhere else (Arch, RHEL, macOS), so it seems to be connected to my EndeavourOS install only.

Where do I need to look to solve this issue? Yay installs packages for me just fine, Firefox let’s me open https pages etc. No other issues regarding SSL.

My desktop is an OptiPlex 9020 that’s plugged in with an Ethernet cable. I’ve tried running a different cable as well as a different switch, but it didn’t solve the issues.

Thanks for any help :slight_smile:

First of welcome to the purple side :imp:. Hope you enjoy using :enos:.

The issue you’re describing is a bit hard to say it’s happening due to this. I tried the repos shown in the code snippets. I was able to clone them without any issues. Both your errors seem to stem from unable to being access the git’s. Are you using a firewall or have the firewall to block anything?

I’m enjoying Endeavour a lot, this has been my only problem so far. I have firewalld running on my desktop as I assume is normal. I also use OPNSense as my router. Other machines on my network don’t have issues with this though.

Also, the repos I’ve shown are just an example, this happens with all of my neovim plugins while using Lazy. I can also clone them as normal if I use the git clone command.

can you just use git and github in daily life? In some country, the connection of github is not stable, most time 404 at github.

I’m in the US and don’t have issues with git at all, except specifically with my EOS desktop. And it’s only when I seem to fetch/clone many repos at the same time, as neovim plugin managers do.

soga. accordind to your reply, it is not network ban. beyond my knowledge. :sweat_smile: