Issues multiple monitor setup

I haven’t posted on the forum before, so it did become a bit of a story.

Hello everyone,

A couple of week ago, I decided to really switch away from windows I need to use it as an daily OS and have windows when i need certain software. I eventually decided on Endeavour, I did run into updates which broke things, but figuring out how to fix it was quick. eg disable updates for the r8168 driver, for now it works, but when it updates the network doesn’t work.
The desktop measurement of choice is KDE Plasma, I just set the theme to Dracula and configure the taskbar. I also like the default application launcher a lot, it shows what the applications do, which is very useful for now because all the applications have different names. And most importantly I can often find the setting I want without using google, eg in gnome I cant find anything.

Now my weird things, I always use rebinded keys, all bluetooth audio and a multiple monitor setup.

  • Rebinding the keys, for now xmodmap will do the trick.
  • Bluetooth audio, the audio quality sucked, I could no get it working in A2DP with pulseaudio. But after switching to pipewire it did work, almost imminently. Only not yet for my XM3 headphones, for some reason. Which is weird because the speaker also has a microphone, on which I can switch the profiles, aka it has same functionality as the headphones.
  • The real issue, the multiple monitors is becoming a real problem. After it goes to sleep or an extra monitor is connected, it fucks up my configuration, which I haven’t been able to figure out.

I have 3 monitors connected, 0, 1 and 2. If I set display 1 as primary, which contains a couple of files and the taskbar. If it comes back from a sleeping display or if I turn on another display (3) (in this case a 4k TV where I play my media on) it decides to move taskbar to another display (also which one is different every time) or sometimes completely disappears and it changes the wallpaper and lockscreen, sometimes. Interesting is when this happens the monitors are still 0, 1, 2, which 1 is still primary. If i than which to another monitor being primary, it just shuffles whatever is on it around and doing it enough times somehow gets it on the right screen again. I’m not the only one having a weird story, I’ve read multiple similar things even going back 2 years.
I did make it usable for now, by disabling the monitors to go to sleep and disconnection the cable to the TV, but it is not what I want.

Anyways, I’m going to moving everything to another ssd. So I will probably, just reinstall the new iso when it releases, because nothing gets lost by doing so atm. This is also a easy moment to click to boxes of the other DE’s and start without al the things I installed to try out and don’t need. I’ve read XFCE does a better job with multiple monitor setups, which I haven’t properly tried yet.

  • Do you have an idea how and if the plasma issue can be fixed?
  • As an alternative which other DE can I try, which supposedly work better with multiple monitors?

Don’t misunderstand me, my overall experience is positive otherwise I haven’t been using it for a couple of weeks already. I also do like plasma, but I can’t keep using it if I can’t fix the issue with multiple monitors.

Thanks,

Welcome to the forum! :smile:

You probably should uninstall r8168 and reboot. The r8169 driver module of the kernel may work better if you have the Realtek 8168 Ethernet card.

To verify that and show some more info, please show the output of terminal command

inxi -Faz

I’m running XFCE with two monitors connected to the laptop. It works great even if one of the monitors is connected via USB-c hub. The monitors remember their settings when i reconnect them after a disconnect. With a bit of customization you can make XFCE look great:

sc-211202-185208

That being said, you can use xrandr on any DE to force the sequence the displays are arranged in with a command like this:

xrandr --output eDP-1 --mode 1920x1080  --output DP-1 --auto --primary --right-of eDP-1 --output DP-2 --auto --right-of DP-1

You can bind the above command to a keyboard shortcut or create an alias for it.

If you wonder how you can adapt it for your displays, first you need to get the names of the monitors with this command (the names are on the last column):

$ xrandr --listmonitors                                                                                                       
Monitors: 3
 0: +*DP-1 1920/598x1080/336+1920+0  DP-1
 1: +eDP-1 1920/344x1080/193+0+0  eDP-1
 2: +DP-2 1920/598x1080/336+3840+0  DP-2

Then simply replace the names in the first xrandr command above.

Cables make a huge difference. I’m not sure how you have it hooked up but Display port is better and if HDMI also use the high spec cables that are certified. HDMI is 2.1 spec now and DPI is 2.0 i think.

https://www.cablematters.com/blog/HDMI/displayport-vs-hdmi

I have tried to uninstall the r8168 driver and then it doesn’t work anymore. (however last week I did pull an ethernet card to use elsewhere, which could have influenced something) My motherboard apparently uses an RTL8111H, according to the manual. Below a snipped of “inxi -Faz”

Graphics:  Device-1: Advanced Micro Devices [AMD/ATI] Ellesmere [Radeon RX 470/480/570/570X/580/580X/590] vendor: XFX Pine
           driver: amdgpu v: kernel bus-ID: 01:00.0 chip-ID: 1002:67df class-ID: 0300
           Display: x11 server: X.org 1.21.1.1 compositor: kwin_x11 driver: loaded: amdgpu,ati
           unloaded: fbdev,modesetting,vesa resolution: <missing: xdpyinfo>
           Message: Unable to show advanced data. Required tool glxinfo missing.
Audio:     Device-1: Intel 100 Series/C230 Series Family HD Audio vendor: Micro-Star MSI driver: snd_hda_intel v: kernel
           bus-ID: 00:1f.3 chip-ID: 8086:a170 class-ID: 0403
           Device-2: AMD Ellesmere HDMI Audio [Radeon RX 470/480 / 570/580/590] vendor: XFX Pine driver: snd_hda_intel
           v: kernel bus-ID: 01:00.1 chip-ID: 1002:aaf0 class-ID: 0403
           Sound Server-1: ALSA v: k5.15.5-zen1-1-zen running: yes
           Sound Server-2: JACK v: 1.9.19 running: no
           Sound Server-3: PulseAudio v: 15.0 running: no
           Sound Server-4: PipeWire v: 0.3.40 running: yes
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Micro-Star MSI driver: r8169 v: kernel
           port: d000 bus-ID: 07:00.0 chip-ID: 10ec:8168 class-ID: 0200
           IF: enp7s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
Bluetooth: Device-1: Cambridge Silicon Radio Bluetooth Dongle (HCI mode) type: USB driver: btusb v: 0.8 bus-ID: 1-2:2
           chip-ID: 0a12:0001 class-ID: e001
           Report: rfkill ID: hci0 rfk-id: 0 state: up address: see --recommends

I did find guides how to modify KDE or XFCE to something I like, but didn’t do to much yet. I’m not going to be doing crazy things just keeping it simple atm, btw your picture looks great.

The position of monitors is from left to right 0,1,2,(3) and whatever happens they do keep the correct position, and the primary monitor is still (1) the middle monitor. Only the taskbar and whatever is on the screen moves, sometimes after sleep or turning the TV on, to a random display.

$ xrandr --listmonitors 
Monitors: 4
 0: +*DisplayPort-1 1920/509x1080/286+1920+0  DisplayPort-1
 1: +DisplayPort-0 1920/509x1080/286+0+0  DisplayPort-0
 2: +DisplayPort-2 1920/509x1080/286+3840+0  DisplayPort-2
 3: +HDMI-A-0 3840/1440x2160/810+5759+0  HDMI-A-0

I tried to turn on and of the monitors, to see if it changes in that list. And of course, now it isn’t doing the weird thing.

Hah, yeah, I know the feeling. In case you still bump into the same thing in the future, the command I referenced earlier can also specify the default monitor:
sc-211202-213533

UPDATE:
So, with the new release of Endeavour, I decided to start fresh. In my first post I mentioned some issues and I really need to give this an update.
First of for me a couple of nice to haves by default, whatever now makes it also show my windows install on the boot screen is the most useful thing. I intend on using eos as main OS and now I can just easily switch to boot windows when necessary without me setting something up. Also the r8168 driver isn’t installed by default anymore, which i couldn’t update or remove otherwise the network wouldn’t work.
With pipewire now being the default and maybe it’s also updated, my MX3 headphones now work flawlessly in A2DP aptX without me doing anything. I mean installing/enabling bluetooth and within a minute everything just worked.
I did also install XFCE, expecting thesame issues in plasma as described before. I did install eos a couple of times in the last month and issue appeared every time. But, well it now it works and it didn’t happen again. (except the default wallpaper decided to disappear)

In the end this post became kind of obsolete very quickly, because most of it appears to be fixed for me at least.