Issues after updating 6months

Updated arch & eos keyring & reboot but then it stuck at this screen.

I know EOS is a rolling release model distro & I should update it more frequently but I wasn’t in home for ~6months & its a PC.

Updated linux & grub from chroot but still same issue.

Within those 6 months, there were some major changes. EnOS has switched from mkinitcpio to dracut.

I wouldn’t be able to tell you offhand how to fix that.

1 Like Its NVIDIA GK208B [GeForce GT 710]

From chroot

1 Like

Within chroot-environment, install dracut package, then run it like in this guide.

1 Like

dracut installed.

# dracut --hostonly --no-hostonly-cmdline /boot/initramfs-linux-lts.img

:+1: (no output)

# dracut /boot/initramfs-linux-fallback.img

:+1: (no output)

Try to install the nvidia packages again, the system warned you that the host, in this case the AUR, was down.

same result :person_shrugging: Will try again after few hours.

Yeah, the AUR has had issues the last couple of days being up and down, probably it isn’t completely solved.

BTW, you could also try and remove the Nvidia drivers, nvidia 470xx isn’t officially supported anymore and given the fact that the last update on that package was in April, I’m not so sure it will work with the current kernel version.


yay -R nvidia-470xx-dkms

removed. Is there anything else to do before I try reboot?

Also remove the utils package, after that, you can reboot the system. When the system is booted up, just toy around if you like the default video drivers.
I’m not completely sure, but if you don’t like it you could install Nouveau, but I’m not sure if it is installed by default. (It is a long time ago that I used a machine with a Nvidia GPU)


yay -R nvidia-470xx-utils

checking dependencies...
error: failed to prepare transaction (could not satisfy dependencies)
:: removing nvidia-470xx-utils breaks dependency 'nvidia-470xx-utils' required by nvidia-470xx-settings
 -> exit status 1

Removed both utils & settings. Rebooting :crossed_fingers:

1 Like

Thanks for saving my files.
Nvidia root cause of evetything.
Before I mess it up again, I’ll backup files & fresh install latest EOS iso. I’ll not use the nvidia, its more of pain than actual use to me.


BTW why neofetch result shows like this? (I didn’t change anything)


Perhaps you have removed the EndeavourOS packages in the past.

IIRC I never touched EOS packages. But I’m reinstalling EOS anyway.
Thanks again for quick support :heavy_heart_exclamation:

1 Like

Best decision ever! Be less geeky, be more intelligent. :slight_smile:

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.