Issue with sleep on Budgie

moved from general to Budgie as issue is not a BUG and more about configure Budgie.

1 Like

I’d like to understand why is it that when my computer goes to sleep automatically, after a few minutes of me not touching it, I’m not able to get it back, whenever the screen turns black, I can’t do anything to get it back working, this didn’t happen to Gnome and Plasma, only with budgie now

please provide some better info:

And welcome on the purple side :enos_flag:

Other Budgie users should give a hint on settings for such stuff on budgie?
As I do not have it installed currently… the only thing I have in mind is that it will got a forked version of gnome-control-center soon as the default gnome one has issue running under budgie?

https://aur.archlinux.org/packages/budgie-control-center

you can try installing:
yay -S budgie-control-center

Hardware Information:

Boot Log:

Systemd Journal:

let me know if you need anything else

btw, didn’t know about the Budgie-Control-Center, I just installed it now, I’ll see if it makes any difference

1 Like

i do not see anything that is going nuts boot journal looks clean.
Could be something you can set up inside config tools for budgie (desktop) or the control center (system) … but log is not showing time when you put system into sleep … so this could tell a deeper story…

journalctl --since "20 minutes ago" | eos-sendlog after sleep and what ever happens rebooting if needed if it is in range of 20 minutes :wink:

1 Like

is this command you gave me supposoed to include my ip in the result? I had commented the result without realising it was there

Äh was not thinking about…
And … is it even possible? It could be by using a cleanup command what we use inside our log tool . . But it does not have option --since for journal

1 Like

wait if that option doesn’t exist than what did I do? LOL

well, I have now disabled the option to automatically suspend, let’s see how that works out

There is always a start for the better… in this case we could try find a way to make use of the
--since "20 minutes ago" option in the eos-log-tool problem is only that it in best case should have an option to set the timespan… @manuel :question: :wink:

I can take a look at it.

it is a very useful log in cases issue happens may on shutdown or while OS usage.

1 Like

Added a user-defined journal selection to eos-log-tool 1.4.14-1.

User can define all options of the journalctl command in a config file
/etc/eos-log-tool.conf.

If no options are defined there, it defaults to --since "20 minutes ago".

1 Like

great great great mr. bash :crown:

20 minutes will be working also in most cases… can get long if journal gets spammed with warnings like it happens some times… but it will do the job if issue happens between boots on running OS or shutdowns…

2 Likes

That 20 minutes is only the default… user can configure the time freely.

2 Likes