Issue with rules

Hi,

I am playing with the BSPWMRC and bspc rules.

I want to set for every monitor specific app.

Atm only working is firefox for monitor/workspace 2

bspc rule -a Chromium desktop=’^2’

What I wanted to set is :

bspc rule -a xfce4-terminal desktop=’^1’

I tried everything , but still not working. When I open terminal for example in window 4 , it is opened there. But Firefox always opens in window 2.

Am I doing something wrong ?

Thanks

Capital ‘x’
write like this

bspc rule -a Xfce4-terminal desktop=’^1’

To know these class names, open the application. Then open a terminal beside it. In terminal, run xprop. Then use your mouse to click on the application, like xfce terminal.
In the output you get, towards the end, you need to look at WM_CLASS(STRING) property. The second value there is what you need to use in bspwm to target application. For example, here’s a screenshot when I run xprop and click on a running instance of xfce terminal.

Edit : I used backtick forward tick or whatever instead of quote. Command should read like one in this comment

2 Likes

Hi,

thank you for your answer. I tried that already, with capital, without, even just terminal

It still opens in current window, not in “1”

Sanity check - did you reload bspwm after making those changes?

sure, super + alt + r :slight_smile:

I’ll open bspwm and check myself

1 Like
bspc rule -a Xfce4-terminal desktop='^1'

This works for me. That may be causing problem is that the quote in the command you posted is of a different kind. Thats my best guess. Or else there is some other conflicting setting?

1 Like

This. And that’s unrelated to WM, DE, whatever. Always use the correct marks.
In this case: ' (single quotation mark, single quote), not ´ (forward tick).

2 Likes

hm, in my bspwmrc marks are the same as posted by @flyingcakes

What I did is copy one from working Firefox rule to terminal rule.
I didnt changed anything… but now when I copied it from here, post above, it working fine…

weird… btw thanks guys

1 Like

Earlier when I posted the snippet, I wasn’t on bspwm. So just copy pasted your earlier snippet (which had backtick or something) and made that capitalization. This time I copied from my configs. So yeah, my first snippet was wrong too.

Forward tick, the backtick points in the other direction: back :wink:

hmm I get it

But does a forward tick button even exist on the keyboard? How do you type it?
Copy paste from the net? :stuck_out_tongue_winking_eye:

Edit : I’m concerned - how did the OP type that? :astonished:

1 Like

Hit the single quote key twice: ´
Hit the single quote key once, followed by space: ’

:wink:

2 Likes

Oh that works. How did I never notice! Cool, thanks.

Sometimes I get bored and I play with the keyboard, and find out about these little things :grin:

1 Like

I have issue with rules sometimes too. :laughing:

Edit: Software rules! :wink:

2 Likes

Nice, I feel better now :slight_smile: hehe

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.