Issue with Luks/Btrfs following a fresh install

I made a fresh install using full disk encryption with Btrfs.
I had issue with the decryption passwd. Using an external bluetooth keyboard and typing the correct psswd, I was denied the decryption of the SSD. Using the internal keyboard of the laptop, typing the exact same psswd, I could decrypt the SSD with no pb. The same external bluetooth keyboard worked for my user psswd.
One error that came up quit often at boot :“invalid sector size 65535”.
1 - I use gparted to clean the disk before install.
2 - Fresh install. KDE and tried Xfce
3 - Same issue on both.
I have now done a fresh install without SSD encryption and no issue to report. External bluetooth keyboard working as expected and no more error :“invalid sector size 65535”
Found an old bug with the exact same error Grub error invalid sector size. I doubt that this is what I am experiencing and in particular comment #9 in the bug. Very strange.
Any help is much appreciated…

I’m not sure I understand your issue correctly, but one thing that comes to mind is the keyboard layout. Does your laptop keyboard have a different layout than the external keyboard? Do you have special characters in your password like @ or \ or #?

This could simply be that you press a key expecting @ to appear, but instead get the character " (which could happen on US vs UK layout keyboard).

By default, EndeavourOS uses an encrypted /boot for maximum security. The big downside of this approach is that it means grub needs to decrypt the kernel/initramfs to start the boot process. That means that functions provided by the kernel(like BT support) may not be available in grub.

If you choose to not encrypt /boot, the decryption will be handled by the initramfs and have the support of the kernel. That being said, I am not sure if BT devices are available at that point in the process either. You could try it and see.

I have decided to go without encryption for the time being. Everything is working as expected without encryption. Posted to get an explanation. My psswd does contain a special character @. The same keyboard shortcut are use to get to that special character @ on the bluetooth and internal keyboard.
As far as bt provided by the kernel not being available during boot makes sense. I did try another distro with the same settings (luks and btrfs) and same issue. Issue probably not related to EOS.
I use encryption provided by the installer.

PS: When choosing to encrypt via the option provided by the installer, its a full disk encryption ?
Probably if I decide to encrypt another time, I should try to no encrypt /boot and see the result.

Don’t know if I was clear enough. Keyboard layout internal and external UTF-8-US. Install is done with UTF8-US.


It is more likely that BT support just isn’t available at that point in the boot process.

But then the ENTER key would not work right? So shouldn’t he get stuck forever on the password prompt?

True. Was never stuck typing in the password with the external bluetooth keyboard.
The same external keyboard is used to set the encryption on the ssd when doing the install.
I guess its a weird one. The keyboard is a logitech with a dongle.