Issue with grub r261

I’m having also a really weird issue even reverting to r261, because the Manjaro drive appears twice then the option that does boot disappears.

Here is the full report:

This looks unrelated to the recent grub issues.

What does efibootmgr -v show?

Running that in the grub prompt grub rescue> says Unknown command efibootmgr.

If your system is booting. Boot of a live iso and run the command. Make sure you boot the iso in efi mode

But do I have to chroot or something? How do I do that?

Not to run efibootmgr. You can just boot off the iso and run it.

Here it is:

[manjaro ~]# efibootmgr -v
BootCurrent: 0004
Timeout: 1 seconds
BootOrder: 0000,0002,0003,0005,0004
Boot0005* UEFI OS       HD(1,GPT,xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx,0x1000,0x96000)/File(\EFI\BOOT\BOOTX64.EFI)0000424f

UEFI OS is the manjaro drive which enters grub in rescue mode.

UEFI OS entries are drive entries you will always have them for any drive that is bootable.
I think we need the full output of efibootmgr not only the first lines …

Is this enough?

[manjaro ~]# efibootmgr -v
BootCurrent: 0004
Timeout: 1 seconds
BootOrder: 0000,0002,0003,0005,0004
Boot0000* Windows Boot Manager  HD(1,GPT,UUID1,0x800,0x96000)/File(\EFI\MICROSOFT\BOOT\BOOTMGFW.EFI)272-characters
Boot0002* ubuntu        HD(1,GPT,UUID2,0x800,0x96000)/File(\EFI\UBUNTU\SHIMX64.EFI)0000424f
Boot0003* debian        HD(1,GPT,UUID2,0x800,0x96000)/File(\EFI\DEBIAN\GRUBX64.EFI)0000424f
Boot0004* UEFI: SanDisk SDDR-BXXX 2920, Partition 2     PciRoot(0x0)/Pci(0x14,0x0)/USB(21,0)/HD(2,MBR,0x14b0441e,0x76e5000,0x10000)0000424f
Boot0005* UEFI OS       HD(1,GPT,UUID3,0x1000,0x96000)/File(\EFI\BOOT\BOOTX64.EFI)0000424f

Not sure if I get your issue.

Are you having trouble with booting EndeavourOS or Manjaro Linux?

I see boot entries neither for EndeavourOS nor Manjaro Linux.

What are the systems installed?

Only windows (Boot0000) and Manjaro (Boot0005) are installed. This latest one goes to grub rescue. Boot0004 is the live iso where I run the efibootmgr command from.

So, I take it as you are having boot issues with Manjaro, right?

I am not using Manjaro but here is an article from Manjaro Linux’ wiki which might be of help to you for restoring its bootloader:

Good luck!

Boot0005* UEFI OS       HD(1,GPT,UUID3,0x1000,0x96000)/File(\EFI\BOOT\BOOTX64.EFI)0000424f

So there is no entry added at all from Manjaro itself… because this one is a default device entry (as I mentioned already before) if it fails to boot Manjaro you will need to fix the grub.cfg or you need to reinstall grub files and set a bootloader-ID what would create a new uefi entry using the id…
# grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=manjaro --recheck

No problem to try find help for Manjore here but i would bet you will find more users with better knowledge around how Manjaro works on the Manjaro ecosystem :wink:


You don’t appear to have an entry for Manjaro at all. You need to manjaro-chroot into your manjaro install and run grub-install

I already did the manjaro-chroot and the grub-install as the link on first post details, then there appear 2 entries for the manjaro drive then only one, so there’s some bug that causes one of them to disappear, either it’s something in manjaro or the computer’s BIOS…

But don’t worry will repeat the process again and see what happens. I’m almost 100% sure it’s a grub bug.

Try excluding --recheck from the command line for grub-install

Ok, booted again from live manjaro-kde-21.3.7-220816-linux515.iso:

   ~  sudo -i
[manjaro ~]# cryptsetup luksOpen /dev/sdc2 manjaro
Enter passphrase for /dev/sdc2:
[manjaro ~]# mount /dev/mapper/manjaro /mnt/
[manjaro ~]# mount /dev/sdc1 /mnt/boot/efi/
[manjaro ~]# manjaro-chroot /mnt/ /bin/bash
[manjaro /]# grub-install --version
grub-install (GRUB) 2.06.r261.g2f4430cc0-1
[manjaro /]# grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=manjaro
Installing for x86_64-efi platform.
Installation finished. No error reported.

Then when I press F11 after reboot, there appear 2 entries for the manjaro install:

  • manjaro (KINGSTON XXX)

Then I boot choosing “manjaro”, which is the only one that works, since the other “UEFI OS” goes to “grub_debug_malloc” error. Yes I can boot to my manjaro system successfully. There I run efibootmgr:

$ efibootmgr
BootCurrent: 0001
Timeout: 1 seconds
BootOrder: 0000,0002,0003,0005,0001,0004
Boot0000* Windows Boot Manager  HD(1,GPT,UEFI1,0x800,0x96000)/File(\EFI\MICROSOFT\BOOT\BOOTMGFW.EFI)272-characters
Boot0001* manjaro       HD(1,GPT,UEFI2,0x1000,0x96000)/File(\EFI\MANJARO\GRUBX64.EFI)
Boot0002* ubuntu        HD(1,GPT,UEFI1,0x800,0x96000)/File(\EFI\UBUNTU\SHIMX64.EFI)0000424f
Boot0003* debian        HD(1,GPT,UEFI1,0x800,0x96000)/File(\EFI\DEBIAN\GRUBX64.EFI)0000424f
Boot0004* UEFI: SanDisk SDDR-BXXX 2920, Partition 2     PciRoot(0x0)/Pci(0x14,0x0)/USB(21,0)/HD(2,MBR,0x14b0441e,0x76e5000,0x10000)0000424f
Boot0005* UEFI OS       HD(1,GPT,UEFI2,0x1000,0x96000)/File(\EFI\BOOT\BOOTX64.EFI)0000424f

Notice that UEFI1 is the same UEFI value and is there 3 times, while UEFI2 is 2 times.

The problem that happened before is after some computer reboots the “manjaro” option disappears, but can try if happens again after certain reboots.

Those aren’t two entries for the Manjaro install.

The UEFI OS entry boots the default OS.

They aren’t booting the same image. See the difference between:


They are booting completely different files.

Looks like so:

[manjaro ~]# ls -lR /boot/efi/EFI/
total 8
drwx------ 2 root root 4096 Nov 21  2020 boot
drwx------ 2 root root 4096 Nov 21  2020 Manjaro

total 232
-rwx------ 1 root root 237568 Nov 21  2020 bootx64.efi

total 228
-rwx------ 1 root root 233472 Aug 30 19:49 grubx64.efi

So should I remove one of the folders, for example /boot/efi/EFI/boot?

No, that is default. It is supposed to be there. If you want to, you can replace /boot/efi/EFI/boot/bootx64.efi with /boot/efi/EFI/Manjaro/grubx64.efi