Issue with grep

few days ago maybe 2, so i did my system update, i got grep update too, after after whatever i type in terminal i got this kind of error- same thing all the time,

egrep: warning: egrep is obsolescent; using grep -E

image

not only cd or sudo , that error all the time pop out
i tried downgrade my grep but still not worked,

Both egrep and fgrep have been deprecated since 2007. GNU Grep 3.8 makes that deprecation visible with the hope that it will induce people to use the standard methods.

HackerNews post: https://news.ycombinator.com/item?id=32795571

Phoronix post: https://www.phoronix.com/news/GNU-Grep-3.8-Stop-egrep-fgrep

1 Like

My guess is that there is something executing egrep inside your zhs configuration, maybe in ~/.zprofile or ~/.zshrc files.

3 Likes

Haha I think everybody should have ripgrep installed :wink:

1 Like

problem solved, yes it was zsh plugin issue, just i find which one then i turned off that plugin-

image

okay do i really need ripgrep after problem solved !?

1 Like

No, you’ve already solved the issue, so no need to do anything else.

1 Like

If the problem is solved, go to the post that helped you the most in solving the problem, in this case @adjagu . Then click on the three horizontal dots, the click on “Solution”. This will trigger the forum software to take appropriate actions.

I’m glad you solved your problem.

Pudge

i think sometimes leave post as not solved, WHY? = because others can write their opinion or questions, but not all the time, sorry btw for leaving this post as not solved !

1 Like

Lol no worries - I have no issues adding my opinion to solved cases :stuck_out_tongue:
There’s usually more than ten ways to skin a cat.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.