Issue with Gnome Extension

Hi everyone,
I’m a newbie to the Linux world and I’ve started my adventure with this distro, EndeavorOS. I chose GNOME as my GUI, the only problem is that I can’t install any extensions. I’ve read various guides, installed various repositories (gnome-shell, chrome, etc.), but nothing works. I tried from the website, of course, but I download the package and there’s no “make” file. I also searched for the “extension manager” application, which allows you to manage and search for extensions directly from the app, but I didn’t understand much there either (I followed a guide on the snapd website, but the installation didn’t work). If someone could give me a hand, I would be really grateful.
I apologize if these are stupid questions, I registered here because I’m eager to learn and not give up on this distro.

You can install extension-manager either from


or from


if you don’t mind flatpak apps.


welcome at the purple games :enos:

I think the issue is that you need
sudo pacman -S gnome-browser-connector
to be able to install extensions over the browser webside:
Basic set can be also installed over the archrepo:
sudo pacman -Syu gnome-shell-extensions

with it you should have a tool in menu to access extensions…


This should be all you need:

1 Like

sudo pacman -S gnome-browser-connector
and follow instructions on:
to install the add-on in firefox…



you can reach extensions app from GNOME menu…

We do not install any per default as 1. we know they will break :wink: and 2. user can decide on how to use them… as this is only one way to do it… you could use packages from AUR or getting them manually from git…

1 Like

With this, I do want to say - when I turned off the extension verification within the dconf settings - I’ve yet to have an extension break on me upon an updated gnome, even from 43->44. But, that is my experience, so take that as everyone will.

will also depend on the installed extensions, but some willbreak from time to time its like AUR stuff it is user content.

1 Like

Thanks everyone, finally I managed to download the extensions through the browser. You all have been very kind.
I just have a small problem, I can’t install Flatpak. I typed “sudo pacman -Syu” to update everything, then “sudo pacman -S flatpak” and it gives me this error:
“Error: Unable to download the package ‘ostree-2023.5-1-x86_64.pkg.tar.zst’ from The requested URL returned error: 404
warning: unable to download some files
error: failed to perform the requested operation (unexpected error)
Errors occurred, no packages were updated.”
What should I do??

Edit: solved it by updating the mirrors (adding a region: Italy and Germany).


Please check this out for setting up flatpak.

1 Like

Or this works well.

Please notice the last line on the page.

Note: graphical installation of Flatpak apps may not be possible with EndeavourOS.

“graphical installation” meaning pamac, discover, etc.

To install, Click on the blued “Install” button and it will show the CLI command to use.
In this case “Alien Arena”.

flatpak install flathub org.alienarena.alienarena


on Gnome you can install gnome-software will work nicely for flatpaks (also a bit slow ) as long as you do not add packagekit to gnome-software and try to use it for pacman packages too that`s not a good idea and strictly not recommended…