Issue with Firefox cursor offset on KDE Plasma 6

I recently updated to KDE Plasma 6, and have been noticing a strange issue with Firefox. If I user Super + (Left/Right arrow key) to align the window to the side of my screen, suddenly there’s a strange offset where Firefox is registering my cursor to be higher than where it actually is, and occasionally seems to be registering as slightly to the left. So far, this issue doesn’t seem to be occurring with any other application besides Firefox.

The issue does not seem to occur as frequently on Wayland, though if I repeatedly use the keyboard shortcut to align the window, I can still get it to happen. The issue does not occur if Firefox is maximized, or aligned to any of the corners of my screen. I’m wondering if anyone else has had this issue, and for any advice on how to fix it. My system is completely up to date. Please let me know if any more information is needed, and I thank you all in advance for your help!

Couple of questions:

  1. The cursor is offset but the click area remains how it should be right?
  2. When you exit or take the cursor off of Firefox, does it automatically correct itself?
  3. Do you have any cursor modifications, ex. extensions or tools modifying it?

Thank you very much for the response:

  1. Sorry, not sure if I phrased it right. My cursor appears like usual, but the area Firefox is registering it as for clicking / selecting things is offset vertically.
  2. On all other applications besides Firefox, the error is not present.
  3. No, I do not. I’ve also tried to disable all my browser extensions on Firefox with no effect.

In honesty, I don’t have too much experience with EndeavourOS yet so I’d wait for someone more experienced to answer but it may be a KDE Plasma 6 issue. Whilst it’s less buggy than the Plasma 5 release, many have been experiencing issues along the lines of this and it may be fixed down the line with an upstream update.

KDE Users Should've Waited - #8 by GolDNenex for more information

But regardless, I’d wait for a more experienced person to answer. But figured I should give a response regardless.

How did you install firefox?

Yeah that’s fair, your response is appreciated nonetheless.

How did you install firefox?

Installed (and attempted to reinstall it) via the package extra/firefox.

Perhaps it is this bug

Also mentioned here:

Although I haven’t had this issue I have had a few others with firefox since the update, cursor block disapears and some pages not loading correctly.) I have notice the issues don’t happen with the x11 session so it may be an issue with wayland.

Same thing here… not really convenient.

From memory, when it occurred for me. Switching to a floating window moved the click-target back into the correct position.

So that might be a workaround until it’s fixed.

Yeap, been doing that, but it’s awful to have to sacrifice space in my monitor for it to work properly :confused: hope it can be fixed soon, what else should we do? or should I report it too in KDE Discuss?

Same Issue here, I filed a bug report.

1 Like

Can you share the link so we can make some extra noise to see if it’s solved sooner? :stuck_out_tongue:

My reported bug seems to be a duplicate of this issue, and actively worked on.

Patience, you must have. We are in the early stages of Plasma 6 :wink:

Which is funny since, I posted that it was probably that bug 2 days ago with a link to that bug report.

Well, today i’ve updated, and all the issue was solved for me, hope you too :slight_smile:

Yep! I can confirm after the update the issue is now no longer present! :smiley:


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.