Issue with Chrome or webkit applications accessing web cam

I have Chrome installed from the AUR but it doesn’t seem to be able to access the cam or mic. Is anyone using this platform to do this and which browser works? I know neither one is popular but this is the platform my family and my wife’s family is on so it’s kind of a necessity.

Change your browser settings so it can access the camera and mic.

Assuming your camera/mic are working in Linux, almost any browser will be able to access them.

Yeah, I did allow it, stiil says it can’t access it. I’ll do some more testing, but it does show up, and webcamoid-git from the AUR shows a picture from it.

Integrated Camera: Integrated C (usb-0000:00:14.0-1):
	/dev/video0
	/dev/video1
	/dev/media0

Little update, same result with the flatpak. I guess I can try Edge or Firefox, but I actually use the sync functions with my phone, and I already use Edge for work and prefer to keep work seperate, so I have to see what my options are. Seems odd that Chrome can’t access the webcam at all though.

Checking your browser settings for access to camera and microphone is another thing, than testing if the cam works on your operating system at all.

Also, some privacy-related browser-extensions do block WebRTC (an API used by browsers for real-time communication via webcam and mic). Could it be you installed some extension, blocking it?

Access to the camera is confirmed. In fact when i first start a FB call the indicator light on the camera goes on for a couple seconds, but never shows an image. No add ons that would block it, i use the same account and add ons on my Windows machines and sync them. Later today I’ll play around with it under Firefox and Edge, see what happens there but migrating browsers on all my other platforms is going to be a pain (work laptop, work terminal server, android phone). Essentially Firefox would be my only other option anyway, i use Edge for work stuff and no other browsers are approved for the work machines.

Ok, looks like it doesn’t work with Edge either. Does work with Firefox so it’s something specific to Edge or Chrome. So I know it’s not going to be supported officially but if anyone has any ideas for getting it going I’d love to hear them.

Yeah, did that already but thanks for the effort :slight_smile:

what is the camera hardware exactly?
i know that Facebook and Skype do not support all devices.
And also i am not patronizing anyone :wink:
Do not use such bad services…
Go for https://meet.jit.si/ start a meeting and invite anyone you want to chat with… its free and working in 90% of cases in any browser and with any hardware… invite members send them the link and they can join from browser or on phone with then option to install the app…

This is a Lenovo Yoga C130 Glass, built in webcam. I think I posted the device info above, and it does work with other applications, including Facebook Messenger on Firefox, just not Chrome or Edge.

And I’m stuck with the service, no way I can get my family off of it, much less my wife’s family.

1 Like

yes i know it is hard to confess others… and it is a common sense that these services from the holy metaverse and google are what is the best solution… but it is indeed not true.

Still strange that it works with firefox and not chrome and chromium based… tried chromium browser also already?

Haven’t tried Chromium yet, mostly because it’s kind of useless to me, I use all the cross-sync stuff to keep my bookmarks managed. Come to think of it I haven’t tried Caprine either, or some other standalone. Of course, anything Electron based uses Chrome as a backend so they might have the same problem…worth a try. Could try Chrome-dev too I guess.

EDIT: so much for that. Caprine and Chrome-beta have the same issue. Only browser that works so far is Firefox. That’s going to be annoying having to switch all my platforms to it…might not have a choice though…ugh…

you could also try using OBS :wink: it has the option to create a virtual camera… what can be used in other apps by choosing OBS virtual cam, there… needs yay -S obs-studio v4l2loopback-dkms and after a reboot it should be an option inside obs-studio.

Ok, OBS is able to view the camera output but Chrome doesn’t see the virtual camera either, all it sees is something called 'Integrated camera" and then a hex ID from the one above and what I get from webcamoid. Something’s missing here. Not sure what. OBS also shows it as 'Integrated camera but with a different hex ID.

This is what works:
Integrated Camera: Integrated C (usb-0000:00:14.0-1)

This is what Chome and Edge see:
Integrated Camera (04f2:b61e)

Clearly Chrome isn’t seeing the right device, but it’s the only device it’s seeing. I seem to have three /dev/video devices (0-2), not sure why.

v4l2-ctl --list-devices
will show devices path and ID

Yeah, here’s what I’ve got after adding the OBS virtual camera:

OBS Virtual Camera (platform:v4l2loopback-000):
	/dev/video2

Integrated Camera: Integrated C (usb-0000:00:14.0-1):
	/dev/video0
	/dev/video1
	/dev/media0

Weird things surely do happen, some times. I’ve experienced similar things with browsers not playing audio from a specific website. The issue never was solved over some years. It just persists, and I have never been able to solve it.

If I were in your situation, I’d try this:

It is in the AUR:
https://aur.archlinux.org/packages/ferdium-bin

Unfortunately this seems to be something specifically Chrome/Webkit based under Endeavour. Firefox works fine. Not even CHrome/Chromium flatpacks work.

Unfortunately I tried switching to Firefox on all my platforms but I’m having too much trouble playing YouTube videos through it, both on my work PC and on Endeavour, so that might not be an option. I’ll have to get Chrome working with FBMessenger calls.

I suppose I should close this thread and open a new one but given that Chrome is A: in the AUR and a Flatpak, and B: is a Google product, I’m not sure I’ll get much support. And then there’s C: Edge is also an AUR thing, and D: it’s also a Microsoft product. Plus E for Electron, which doesn’t work either. :slight_smile:

Perhaps you might want to take a look at Franz:

It has an AppImage and it is in the AUR too:

https://aur.archlinux.org/packages?O=0&K=franz

A flatpak version as well:

https://flathub.org/apps/details/com.meetfranz.Franz

Disclaimer: I haven’t used this application myself, so please do your own research about it to see if it meets your criteria