Issue with boot order after switching to systemd-boot

From the # prompt, try running bootctl install again. Then run bootctl status

For the record, what that means is that /dev/disk/by-partuuid/5556cfb4-b620-6a48-84af-d99551c45101 is a link to /dev/nvme0n1p1. /dev/nvme0n1p1 is your EFI partition. Since your EFI entries point to 5556cfb4-b620-6a48-84af-d99551c45101 which is your EFI partition, that means that part is correct.

I hope I did this right:

System:
Firmware: UEFI 2.70 (American Megatrends 5.17)
Secure Boot: disabled
Setup Mode: user
TPM2 Support: yes
Boot into FW: supported

Current Boot Loader:
Product: systemd-boot 249.3-1-arch
Features: ✓ Boot counting
✓ Menu timeout control
✓ One-shot menu timeout control
✓ Default entry control
✓ One-shot entry control
✓ Support for XBOOTLDR partition
✓ Support for passing random seed to OS
✓ Boot loader sets ESP information
WARNING: The boot loader reports a different ESP UUID than detected!
ESP: /dev/disk/by-partuuid/31323032-3830-4632-b232-303331313431
File: └─/EFI/BOOT/BOOTX64.EFI

Random Seed:
Passed to OS: no
System Token: set
Exists: yes

Available Boot Loaders on ESP:
ESP: /efi (/dev/disk/by-partuuid/5556cfb4-b620-6a48-84af-d99551c45101)
File: └─/EFI/systemd/systemd-bootx64.efi (systemd-boot 249.4-1-arch)
File: └─/EFI/BOOT/bootx64.efi (systemd-boot 249.4-1-arch)

Boot Loaders Listed in EFI Variables:
Title: Linux Boot Manager
ID: 0x0001
Status: active, boot-order
Partition: /dev/disk/by-partuuid/5556cfb4-b620-6a48-84af-d99551c45101
File: └─/EFI/systemd/systemd-bootx64.efi

    Title: EndeavourOS
       ID: 0x0000
   Status: active, boot-order
Partition: /dev/disk/by-partuuid/5556cfb4-b620-6a48-84af-d99551c45101
     File: └─/EFI/EndeavourOS/grubx64.efi

Boot Loader Entries:
$BOOT: /efi (/dev/disk/by-partuuid/5556cfb4-b620-6a48-84af-d99551c45101)

Default Boot Loader Entry:
title: EndeavourOS (5.14.5-arch1-1)
id: 85a1bc4e11ee4141a99892145aa64a1c-5.14.5-arch1-1.conf
source: /efi/loader/entries/85a1bc4e11ee4141a99892145aa64a1c-5.14.5-arch1-1.conf
version: 5.14.5-arch1-1
machine-id: 85a1bc4e11ee4141a99892145aa64a1c
linux: /85a1bc4e11ee4141a99892145aa64a1c/5.14.5-arch1-1/linux
initrd: /85a1bc4e11ee4141a99892145aa64a1c/5.14.5-arch1-1/intel-ucode.img
/85a1bc4e11ee4141a99892145aa64a1c/5.14.5-arch1-1/initrd
options: root=UUID=05d0b3ad-6cb8-4897-96cf-5138d83a87c3 rw rootflags=subvol=@ quiet resume=UUID=3d878d1e-73ca-4e63-8c16-d187f291cb5d loglevel=3 nowatchdog

What does ls -l /dev/disk/by-partuuid/31323032-3830-4632-b232-303331313431 show?

Also, what does efibootmgr -v show now?

lrwxrwxrwx 1 root root 10 Sep 18 19:15 /dev/disk/by-partuuid/31323032-3830-4632-b232-303331313431 → …/…/sda2

and

BootCurrent: 0002
Timeout: 0 seconds
BootOrder: 0001,0002,0000
Boot0000* EndeavourOS HD(1,GPT,5556cfb4-b620-6a48-84af-d99551c45101,0x1000,0x100000)/File(\EFI\EndeavourOS\grubx64.efi)
Boot0001* Linux Boot Manager HD(1,GPT,5556cfb4-b620-6a48-84af-d99551c45101,0x1000,0x100000)/File(\EFI\systemd\systemd-bootx64.efi)
Boot0002* UEFI: USB, Partition 2 PciRoot(0x0)/Pci(0x14,0x0)/USB(19,0)/HD(2,GPT,31323032-3830-4632-b232-303331313431,0x3a80bc,0x31000)…BO

OK, so the warning you are getting in bootctl is caused by the fact that you are booted off the ISO so that is fine.

That all looks fine.

Try rebooting.

GRUB rescue again. This is getting really confusing…

Can you share a picture of your BIOS boot order screen?

Go down to UEFI Hard Disk Drive BBS Priorities, go into that sub menu, and select Linux Boot Manager.

1 Like

You’ve got to be kidding me. That was all I had to do??! I can’t… Thank you so much. So, will this method work if I were to reinstall EOS?

2 Likes

For the record, this:
image

Means you are explicitly booting grub.

1 Like

Yes.

Alright, I am going to do a fresh reinstall to remove any problems I had left behind by doing this, as I have done something in gparted.

You shouldn’t need to do that

Well, I am on a fresh install anyway, so why not?

Using reinstall as a catch all for issues is a bad habit vs learning to fix them

As a side note, I have no idea why your bios/firmware is ignoring the boot order set by efibootmgr

Manufacturers like to do weird things in bios lol

My gigabyte board does some real wonky things at times so I avoid touching the bios

By the way, thanks for all the help. Who knew changing a bootloader was so far, but so close all along?

1 Like