Issue on suspension

Hello
first of all thank you all for your helps

I use endeavour os on my old pc lately and it run well but i have a major problem and that happens after suspending the pc , the screen corruption happen and no key works to kill the user interface
as well as I’m quite novice please excuse me if it was the easy and the stupid question cause i have no idea what the problem is.
btw i use Nvidia GeForce 9800GT (GPU) and AMD Phanom II x4(CPU


)
thanks

Welcome.

Without a lot more information there little we can do to help you. Please look over this and give us some information.

Please also - you say suspension. . Do you mean sleep (suspend to ram) or do you mean hibernate (suspend to disk).

Again welcome!

1 Like

Welcome to :enos: forums.

This is from the top of my head seems when you’re coming out of suspension Nvidia driver seems to be refusing to load properly and crashes. Which intern freezes your entire system. Please read the link provided by @fbodymechanic and give some more details. Because its Nvidia more info will help a lot.

1 Like

Hello again
about the type of suspend , I found this two file :

/sys/power/mem_sleep: s2idle [deep]
/sys/power/state: freeze mem disk

about the system logs :

hardware log : https://clbin.com/30zMJ
answer to journalctl -b -0 : https://clbin.com/l48pu
answer to journalctl -b -2 : https://clbin.com/vfJAZ

i wish sending this logs be accurate enough but I’m not sure ,
is there any other type of log file that i missed them?
thank you

Do you have no swap file or partition?

Edit: You can create a swap file and add it to your fstab.

https://wiki.archlinux.org/title/swap#Swap_file

1 Like

looks like art :art:
But very common special on Nvidia driver usage.
could help putting the nvidia modules in initramfs, as described there:

1 Like

@mr.gholami

It could be Nouveau open source drivers also causing the issue. You could install the nvidia-340xx-dkms drivers from the AUR. Plus there are the additional enhancements.

1 Like

I looked at you. My desktop does not have a desktop when I return after a suspend, only a white screen with the mouse cursor, but there is a virtual terminal so I can turn it on or restart the machine. There is also an Nvidia external video card. I will test it during other distro occasions as well. I rarely use suspension.

1 Like

thank you but
i have done that but the problem still remains.

thank you i visited your link and i had done some of them and initramfs but still the same problem …

i tried to install nvidia-340xx-dkms but at first it needed to install linux419header and after installing that it need nvidia-340xx-utils that I’m trying to install but for no reason it say package not found…

Well, under another distribution, namely Linux Mint, I also tested how this particular suspension works. Same desktop, same Nvidia card, same nouveau driver. Well, I have found that the machine wakes up normally after a suspension. So it follows that the phenomenon is highly distribution dependent. I will still be able to try it occasionally under open SUSE Tuimbleweed. In any case, when using EOS, intervention is required to return the desktop after suspension, but the virtual terminal is available.

https://wiki.archlinux.org/title/NVIDIA/Troubleshooting#System_does_not_return_from_suspend