Issue after Installation

Hi there!
Happy to see a friendly community about this interesting distribution :slight_smile:

I tried EndeavourOS on a vmachine: i got so happy that I decided to switch it for my personal machine, from Fedora.

I installed EOS with Plasma but at the first boot I only see cursor and black screen :frowning: i also tried standard version with XFCE and same happened.

Live version is running perfectly so I don’t understand.

How I can perform some actions for debugging and help you (and me then lol)?

I have an AMD Ryzen 5 1600X and nVidia GTX 1070ti

Thanks everyone! :slight_smile:

Welcome aboard, a few questions. Which ISO did you use? Did you select nonfree when booting the live key? And lastly can you please launch the live key and input inxi -Fxxxza in you terminal and post the output? Please use the </> to properly format you posted terminal output. Thanks

2 Likes

Thanks!

I downloaded this one: https://github.com/endeavouros-team/ISO/releases/download/1-EndeavourOS-ISO-releases-archive/endeavouros-2020.09.20-x86_64.iso.torrent
and checked ISO file with the sha512

I also selected nonfree when booting: in every case live version has no problem.

I will try that input this evening :wink:

1 Like

Then from what I’ve personally seen with various OS’s it may just be a matter of how you’re formatting your drive. Is this a single OS install or are you dual booting, and if dual booting are the OS’s going to be on the same drive?

I tried same configuration with other distro and it works (also on manjaro that has similar installer, I guess).

I’m dual booting with Windows 10 in a different drive:

2 ssd

1 -> Single partition, Windows 10
1 -> 4 partitions:

  • /boot ext4
  • swap
  • /home ext4
  • / ext4

I disabled UEFI and my MBR is on the ssd with Linux

OK other than choosing MBR over UEFI looks like you know how to do your partitions. As for Windows there will be 2 partitions under MBR and 3 under UEFI.

EDIT:

On second look your boot partition should be fat32 not Ext4, and I’m assuming that last partition is just storage?

1 Like

Any particular reason why?

Welcome aboard!

2 Likes

Hi and welcome :wave:
Nice username! I had Lain Iwakura on nearly all my online profiles until a few months back. Switched them with a different pic now.
But yes, I’ll never forget the most epic anime opening ever

P R E S E N T . D A Y !
P R E S E N T . T I M E !
H A . HA . H A . H A!

1 Like

Thanks! :slight_smile:
I just don’t trust UEFI and Secure Boot to check my hardware and system :frowning:

Hi! Thanks! :slight_smile:

it’s a very epic opening! <3
That anime is such as very cool and weird at the right point

1 Like

Last partition is my root partition :slight_smile:
/boot is ext4 because it’s managed by Linux: do you mean I should set as fat32?

Did you turn off Secure Boot in the bios? it and CSM should be turned off. Also need to turn off Fast Boot in Windows.

My bad fat16, but yes.

Guess it is a good thing that secure boot is not supported by arch linux. There is nothing scary about uefi :wink:

2 Likes

@lain
Welcome. First thing is you shouldn’t do is disable UEFI. That has nothing to do with secure boot. You should be turning off secure boot and fast boot in UEFI. The reason you had a problem with the boot is likely due to the Nvidia GTX 1070ti. I see you are also booting with Windows 10 as dual boot. There is a feature in Windows 10 that you should also disable which is fast start up because it use hiberfile and will cause problems to boot. Windows should already be installed in UEFI as that is the way it comes. You shouldn’t be trying to install using MBR. You want to use UEFI and boot from the EFI partition as Windows does. Using UEFI you create an efi partion 300MB as /boot/efi and flag it boot instead of using MBR and ext4 as boot.

It would be helpful if you could post your hardware specs. Install inxi and post the output of
inxi -Fxxxa --no-host

Also which desktop were you installing? Did you check the nvidia drivers on the install?

If it were me i would turn UEFI back on. Disable secure boot and fast boot in UEFI. Go into windows 10 and turn off the fast start up feature. Then run the live ISO again and use gparted to redo your partitions as follows. Then run the installer and choose manual partitions and go through the process of selecting the partitions you have designated and mark them accordingly for each. Then click next and go through the install selecting nvidia drivers also.

300MB /boot/efi flag /boot fat 32 (recommended minimum) I use 512MB
/ root
/home
/swap

Edit: Hope this helps. :slightly_smiling_face:

3 Likes

Thanks, much clearer than what I said.

2 Likes

THANK YOU GUYS!!! My OS finally booted correctly :smiley: great!
I finally found people that help me like friends. Finally a power community that not critics but help <3

Only issue is the Grub doesn’t recognize Windows 10: i have to open another ticket or can follow on this one?

In every case, I post my inxi -Fxxxa --no-host

System:    Kernel: 5.8.10-arch1-1 x86_64 bits: 64 compiler: gcc v: 10.2.0 
           parameters: initrd=\arch\boot\intel-ucode.img initrd=\arch\boot\amd-ucode.img 
           initrd=\arch\boot\x86_64\archiso.img archisobasedir=arch cow_spacesize=10G 
           archisolabel=ENDEAVOUROS earlymodules=loop modules-load=loop rd.modules-load=loop 
           i915.modeset=1 radeon.modeset=1 nvidia.blacklist=yes modprobe.blacklist=nvidia 
           nouveau.modeset=1 nouveau 
           Desktop: Xfce 4.14.2 tk: Gtk 3.24.20 info: xfce4-panel wm: xfwm4 dm: LightDM 1.30.0 
           Distro: EndeavourOS 
Machine:   Type: Desktop Mobo: ASRock model: AB350 Gaming K4 serial: <superuser/root required> 
           UEFI: American Megatrends v: P6.40 date: 08/31/2020 
CPU:       Info: 6-Core model: AMD Ryzen 5 1600X bits: 64 type: MT MCP arch: Zen family: 17 (23) 
           model-id: 1 stepping: 1 microcode: 8001138 L2 cache: 3072 KiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 86267 
           Speed: 3009 MHz min/max: 2200/3600 MHz boost: enabled Core speeds (MHz): 1: 3279 
           2: 1846 3: 1880 4: 1879 5: 1829 6: 1880 7: 1879 8: 1880 9: 3179 10: 1845 11: 1840 
           12: 1880 
           Vulnerabilities: Type: itlb_multihit status: Not affected 
           Type: l1tf status: Not affected 
           Type: mds status: Not affected 
           Type: meltdown status: Not affected 
           Type: spec_store_bypass 
           mitigation: Speculative Store Bypass disabled via prctl and seccomp 
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
           Type: spectre_v2 
           mitigation: Full AMD retpoline, IBPB: conditional, STIBP: disabled, RSB filling 
           Type: srbds status: Not affected 
           Type: tsx_async_abort status: Not affected 
Graphics:  Device-1: NVIDIA GP104 [GeForce GTX 1070 Ti] vendor: Micro-Star MSI driver: nouveau 
           v: kernel alternate: nvidia_drm,nvidia bus ID: 0a:00.0 chip ID: 10de:1b82 
           Display: server: X.Org 1.20.9 compositor: xcompmgr driver: modesetting 
           unloaded: fbdev,vesa alternate: nouveau,nv display ID: :0.0 screens: 1 
           Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2") 
           s-diag: 582mm (22.9") 
           Monitor-1: DP-1 res: 1920x1080 hz: 60 dpi: 92 size: 531x299mm (20.9x11.8") 
           diag: 609mm (24") 
           Message: Unable to show advanced data. Required tool glxinfo missing. 
Audio:     Device-1: C-Media CMI8788 [Oxygen HD Audio] vendor: ASUSTeK CMI8786 
           driver: snd_oxygen v: kernel bus ID: 05:04.0 chip ID: 13f6:8788 
           Device-2: NVIDIA GP104 High Definition Audio vendor: Micro-Star MSI 
           driver: snd_hda_intel v: kernel bus ID: 0a:00.1 chip ID: 10de:10f0 
           Device-3: AMD Family 17h HD Audio vendor: ASRock driver: snd_hda_intel v: kernel 
           bus ID: 0c:00.3 chip ID: 1022:1457 
           Sound Server: ALSA v: k5.8.10-arch1-1 
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: ASRock 
           driver: r8169 v: kernel modules: r8168 port: c000 bus ID: 09:00.0 chip ID: 10ec:8168 
           IF: enp9s0 state: up speed: 1000 Mbps duplex: full mac: 70:85:c2:47:67:20 
Drives:    Local Storage: total: 2.95 TiB used: 1.87 GiB (0.1%) 
           SMART Message: Unable to run smartctl. Root privileges required. 
           ID-1: /dev/sda vendor: Drevo model: D1 SSD size: 111.79 GiB block size: 
           physical: 512 B logical: 512 B speed: 6.0 Gb/s serial: TA1851814450178 rev: 4B0 
           scheme: MBR 
           ID-2: /dev/sdb vendor: Seagate model: ST2000DM006-2DM164 size: 1.82 TiB block size: 
           physical: 4096 B logical: 512 B speed: 6.0 Gb/s rotation: 7200 rpm serial: Z4Z951NW 
           rev: CC26 scheme: GPT 
           ID-3: /dev/sdc vendor: Crucial model: CT250MX500SSD1 size: 232.89 GiB block size: 
           physical: 512 B logical: 512 B speed: 6.0 Gb/s serial: 1750E107BC9B rev: 010 
           scheme: MBR 
           ID-4: /dev/sdd vendor: Crucial model: CT750MX300SSD1 size: 698.64 GiB block size: 
           physical: 512 B logical: 512 B speed: 6.0 Gb/s serial: 161412661C37 rev: R060 
           scheme: MBR 
           ID-5: /dev/sde type: USB vendor: Lexar model: USB Flash Drive size: 119.24 GiB 
           block size: physical: 512 B logical: 512 B serial: AA444JF63ND2PCCE rev: 1100 
           scheme: MBR 
           SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure? 
Partition: ID-1: / raw size: N/A size: 10.00 GiB used: 55.4 MiB (0.5%) fs: overlay 
           source: ERR-102 
Swap:      Alert: No Swap data was found. 
Sensors:   System Temperatures: cpu: 30.4 C mobo: N/A gpu: nouveau temp: 45.0 C 
           Fan Speeds (RPM): N/A gpu: nouveau fan: 0 
Info:      Processes: 290 Uptime: 3m Memory: 15.56 GiB used: 887.2 MiB (5.6%) Init: systemd 
           v: 246 target: multi-user.target Compilers: gcc: 10.2.0 Packages: pacman: 895 
           lib: 196 Shell: Bash v: 5.0.18 running in: xfce4-terminal inxi: 3.1.08 

/dev/sda: drive with Windows 10
/dev/sdc: drive with my Linux installation

other drives are storage.

Thanks so much! <3

2 Likes

Technically since this thread is marked solved you should but your second issue is probably a symptom of the first. That said I think it is easy to fix. Did you update grub and reboot after this? If not in a terminal do:
sudo grub-mkconfig -o /boot/grub/grub.cfg
Then:
systemctl reboot
Look and see if win 10 is in the menu now.

1 Like

I really thank you but unfortunately it didn’t work :frowning:
For sure i wrong something during partition.

I am going to open new thread :wink: thanks guys!!!

1 Like

First thanks for that, on average peeps here do tend to be far more friendly and helpful than other Linux forums. Now as for Win 10 can you press F8 or whatever key it is on your system for the bios boot selection menu and see if you can boot 10 from there? The if you can I would do what @Elloquin suggested.

1 Like

Glad you got things (mostly) working for your set up! Welcome to the community :beers:

1 Like