ISO Live boot fails AHCI controller unavailable

Hello, When I try to run any of the latest few releases, the installer gets to “Triggering uevents” and then “AHCI controller unavailable!”.

I’ve tried using cassini and artemas ISO’s, nvidia/normal options, ventoy and burned to a usb with several different tools ( usbwriter, rufus, etcher) but no matter what I try I either get the screen pictured below, or an error about /dev/by-label/EOS_somthing/ not being ready in 30 seconds, in the second scenario most of the time my keyboard will not work in the offered terminal, nor will any one I plug in, I have tried everything I can think of but nothing works,

Any suggestions?

Thank you,

You will need to reboot your computer then press F2 or del or whatever opens up your BIOS settings.

In the BIOS you need to ensure that AHCI is enabled.


I checked the settings in bios, the only reference to AHCI I could find was under SATA configuration, which was already set to AHCI Mode.

Have you tried other usb ports to boot from?

Edit: It may be an issue with booting from a usb 3.0 port?

I have tried the front IO ports, and one on my motherboards IO, with the same result.

Do you have secure boot and CSM disabled in the Bios?

What motherboard brand and model and Bios version?

Edit: Looks like an MSI board?

The motherboard is a MPG X570 GAMING PLUS (MS-7C37), and the bios version is E7C37AMS.A40, build date 09/10/2019.

Edit: yes, both CSM and secure boot are disabled

I have the same motherboard. The UEFI Firmware(Bios) needs to be updated as there are many updates. The latest is 7C37vAI dated 2022-08-19

I will give that a try!

This one is mine and up to date.

  Type: Desktop Mobo: Micro-Star model: MPG X570 GAMING PLUS (MS-7C37) v: 2.0
    serial: <superuser required> UEFI: American Megatrends LLC. v: A.I0
    date: 08/10/2022

It is working, installing now!

Thank you so much!

1 Like


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.