Iso 2021-08-27 run on virtual machine but not boot pc

I install EOS with ISO 2021-08-27 in a virtual machine and the installation is ended well and everything works fine.
After that I try to install in a laptop where now is installed linux lite.
when I boot the computer I can access to boot menu
image2
and i choose usb
image1
I don’t know why I have all that option, when I installed linux lite I formatted completely the main hard drive.
after that I choose Endeavour
image0-1
but the system boot linux lite and EOS do not start like with the virtual box.
I check a lot around the web.
I disable the sefety bot from linux lite.
But I’m not able to access to Bios setup, If I choose that option the system boot normally.
I try several time, followind the wiki I tried to download another ISO same version other repositry, I try two different usb Key.
But I haven’t found a way yet.
… my computer has this configuration: http://ix.io/3EXv

First thing is do not use a three month old iso. Use the latest from the website:
https://endeavouros.com/latest-release/

He is using the latest isn’t he?

I was think this is the last one.

You’re right i thought there was a newer one. Too many test isos for me.

That boot menu is a bit of a mess! However, your system appears to start the EndeavourOS boot from USB.

There is a Lenovo support page that may help:
https://pcsupport.lenovo.com/pe/en/products/LAPTOPS-AND-NETBOOKS/100-SERIES/110-15ACL/80TJ/80TJ00LRUS/solutions/HT500216

I tried all that suggestion, apart that considering to use windows that i don’t have any more.
But when I’m in the menu:
image2
and I select Bios setup It doesn’t work and the pc boot normally with linux lite

The strange thinks is that if I try to boot with another linux distribution like ubuntu it works when I choose boot from usb. It does not work only with Endeavouros.

Are you using the same Verbatim USB stick when Ubuntu boots from USB? What application did you use to put Endeavour on the USB stick?

I try with two different USB stick, I use dd like indicate in the wiki

Hmm… this is odd :thinking:

I reach this menu:
image0-1
but when I select EndeavourOS like in the image the system boot normally with light linux

looks like some settings in Bios preventing from boot the hybrid ISO (ISO can boot as DVD or from USB without any needed changes).
And that you are not able to access Bios could be related to that too… is the way on power off machine and directly after power immediately and repeatedly press (Fn+) F2 or F2. Accessing the BIOS may take multiple attempts. doe snot work too?

I would check if some settings in Bios could be related to not be able to boot ISO.

It looks like the laptop is UEFI. You can enter the UEFI settings three different ways. As @joekamprad posted and also the Novo button and also Another way to enter the BIOS is to press F12 and then choose to Enter the setup from the Boot menu.

I try to follow all the suggestion in the web and from the lenovo website
fn f2 and fn f12 I try to press all the button in my keyboard :slight_smile:

The fn + f2 you have to hit the f2 repeatedly.

I try several time fn+f2 and only f2 , just after press power button, an than boot and that again i try in different time during the boot, the only way is with the small button an the side of laptop to acces to the blu menu but also this not works

So if you highlight the Bios Setup and enter it doesn’t go into it? Strange. There has to be a way it works.

yes this is my main problem

I try just now to boot with standard arch linux iso and it works
when I try to in the blu menu to boot from usb it works:
image1
an then:
image0
this means that there is some difference with the iso of EndeavourOS