Iscan and iscan-data no longer in AUR

Today I did an update via yay and got the following message:

:: Searching AUR for updates...
 -> Missing AUR Packages:  iscan  iscan-data

Should I be worried since I have an Epson WF-3520 with scanner? Plugins and driver package epson-inkjet-printer-201212w still exist. Just no iscan nor iscan-data.

Not 100% sure here - but it may be removed from the AUR because it is now in the main repos. I see that community hosts both iscan and iscan-data now. Presumably you can remove the Aur version, and do a normal pacman -S iscan iscan-data. (not sure you would even need to remove the AUR version, it might get replaced by the repo one)

1 Like

This is common when something moves from the AUR to the repos. Either wait a little while or switch to a more recently updated mirror.

As long as the package name is the same, there is no need to remove it, future updates will come from the repos.

1 Like

Thanks @freebird54 and @dalto , I’ll wait a while to see what happens. I did a reflector-simple prior to using yay, but still no iscan in community. Impatience rears its ugly head once again.


I was able to solve this problem earlier today as follows:

I first completely uninstalled iscan and iscan-data:

$ yay -Rsn iscan iscan-data

I then reinstalled iscan and iscan-data:

$ yay -S iscan iscan-data

yay tells you that iscan-for-epson-v500-photo and its dependencies will be installed instead of the requested packages:

:: Checking for conflicts...
:: Checking for inner conflicts...
[Repo:2]  libjpeg6-turbo-1.5.3-2  libpng12-1.2.59-2
[Aur:1]  iscan-for-epson-v500-photo-2.30.4-3
[Aur Make:1]  deb2targz-0.1-7

After installation completed, I found that iscan appears again in my application menu, iscan launches normally, and my Epson Perfection 1240U scanner works as before.

To confirm that iscan-for-epson-v500-photo has provided iscan, run this command:

$ yay -Qi iscan

Name            : iscan-for-epson-v500-photo
Version         : 2.30.4-3
Description     : iscan (from Epson) with the plugin for scanner Epson V500 Photo, also called
                  GT-X770 - iscan[community] is out-of-date and buggy
Architecture    : x86_64
URL             :
Licenses        : custom:EPSON
Groups          : None
Provides        : iscan  iscan-data  iscan-plugin-epson-v500-photo
Depends On      : libjpeg6  libpng12
Optional Deps   : None
Required By     : None
Optional For    : None
Conflicts With  : iscan  iscan-data  iscan-plugin-epson-v500-photo
1 Like

Thanks @kwg . Worked like a charm. Actually all three replies are the solution, I just picked the last because it was the fullest and I had to remove iscan and iscan-data and then reinstall them.

1 Like

I was curious so I did a little investigating here.

The issue, in this case, is not that these packages moved from the AUR to the repos, it was that they were in the repos and had been removed.

The reason they were removed was due to instability with the version of glibc currently in the Arch repos.

So, it is possible/likely you may see stability issues with the version you have installed from the AUR as well.


Yes, the new AUR version points out in its description that the community version was buggy:

I was having problems with the version of iscan ( that was removed from the community repo. Most frustrating, it was impossible to select a rectangular area of the preview image for final scanning. I’m pleased that this problem has been resolved in the new version (2.30.4), and I haven’t experienced any other problems, so far. :crossed_fingers:

Yes, the buggy rectangular selection was a pita. I always had to select the larger area and use Krita or Gimp to crop. So far 2.30.4 seems to work for me too.

So far, so good. Have my fingers crossed.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.