Is there any good solution for file transfer between Linux and Android?

Atm Linux is driving me nuts once again. The mtp is just awful. Since yesterday I try to copy some audiobooks from my laptop to my phone and I still couldn’t finish the job. Sometimes you can copy a few folders before it starts hanging, sometimes it doesn’t work at all. When it hangs you have to disconnect the phone, connect it again, switch to file transfer and pray that it works again. Awful, just awful and after it hangs up for the third, fourth, fifth time I just wanna punch the screen.
So I thought I use KDE Connect to transfer the files. That works but for whatever reason all the files get automatically renamed from .opus to .oga :crazy_face:
It’s like Linux is trying to mock me…

So, any better solution out there than whatever Linux uses out of the box? (A wired connection (USB) would be preferred)


I mean, I have a pixel 6a that I send files to using the usb c adapter. Never had any issues with it. Maybe it has to do with your cable or port?


There’s a lot of ways to transfer files, but if a direct connection is giving you problems maybe a cloud share service like drop box would work for you?


Back in 2021, I tried USB file transfer and it didn’t really work so I had to use KDE Connect, but not long after it suddenly just started working and still works. I just need to plug my phone with usb or usb-c, give file permissions and it’s ready to go.

Doesn’t USB work for you without additional steps?

If it doesn’t, well I guess you can go crazy and setup an FTP server on your desktop and use an FTP client on your phone (I’m not aware of any actually), or you can be crazier and set up an HTTP server on your desktop and use your phone’s browser to receive the files.

I don’t recommend the http method, but the FTP method isn’t that bad actually and it’s bidirectional file transfer. This is how I transfer files between my desktop and my 3DS without having to take out the sd card.


I am not using this myself but Warpinator should do the job.
You might want to look into it.


I used to use a ‘FIles’ program that no longer can be found on Android, but lately I just use SSH for transfers… at the computer end I have FileZilla to make it easy/GUI driven. This will work on wifi or whatever you have enabled for networking (including USB hookups I guess) and has the great advantage of being under your personal control!


I use kdeconnect and localsend depending on which de/wm I use.

1 aur/localsend-bin 1.10.0-1 [+5 ~1.24] [Installed]
    An open source cross-platform alternative to AirDrop

oldschcool per usb-cable: install android-file-transfer

KDE connect is so far the best solution


KDE Connect works great, but here are a couple of other ways that I’m currently using:

  1. scrcpy - it’s not just for screen mirroring, you can also drag-and-drop files from your desktop to your phone.
  2. good old SSH - I installed an SSH server on my phone via termux, then use rsync or unison to keep my Obsidian Notes synced.
1 Like

I use the file browser and a usbc cable or kdeconnect.

Both work awesome. Cable connection is simple and fool proof. Works every time. Kdeconnect can be a little temperamental, but usually just works.

1 Like

take a look here What application have you recently discovered? - #261 by swh. super fast

its called localsend. Any infos on .

download from here:

Edit: it worked perfectly with my Pixel4a running GrapheneOS on it


Now that’s interesting! I had those problem on different machines with different cables. Maybe the problem is more complicated 'cause the copy process usually starts acting weird when there’s a lot of small files, rarely at larger files. Current situation consists of a few thousand small files in about 70 folders.

Currently at work, will check out all other answers later. Thx so far everybody!

BTW: Can anyone confirm the KDE Connect bug? I found this from 2019:

1 Like

There is only one response :

:sweat_smile: :sweat_smile:


Not for me with wired USB connection, I just need my file manager Thunar, only gvfs-mtp+libmtp are installed. I don’t transfer a lot of files at the same time though.

1 Like

Had my share of phones over the years using LineageOS and always used mtp without issues. Just once it was acting up and a simple reboot fixed that issue. Good Luck.

1 Like

I’ve used warpinator before and it works well


There exists a classical method of transferring files via Filezilla.

Though I had never used this as my USB transfer method works well and enough.

1 Like

OK, quick update here.

I installed Android File Transfer, couldn’t connect to my phone at all.
Installed Android udev and then Android File Transfer connected to my phone.
I started copying and it looked like it works…until about 15% when the connection to the phone was once again lost and the copy process aborted.
So I thought :fu: mtp, I will now just copy everything to a stick and transfer it to my phone using USB OTG.
So I started copying and guess what?


And that is USB 3.1!

Took forever and three days to finish and I had to skip two folders. For the first one Dolphin told me that some filenames contain characters not supported by ExFAT. Although they don’t and manually creating the folder and copying the files into did work.
On the second case Dolphin told me that it can’t create the folder itself. Again, manually creating the folder and copying the files worked.
So everything was finally on the stick and I tried to unmount it. Guess what? Didn’t work.
So I tried to shut down the system. Yeah, didn’t work either, got stuck at “shutting down in 1 second” for 10 minutes until I powered if the system manually.

As I said above, it really feels like Linux is mocking me. Nothing works lately.
I don’t feel well and I don’t have nerves for all of this at the moment.
This may be my last post for a while. I have to think things over.

Thx everyone for your help!

1 Like

I’m done with cables as well, my phone connection isn’t in a good state, was driving me nuts for some time, so I came up with two solutions:

  1. Shared folder with syncthing, so I just drop files on the folder and let my phone receive it, also using for backup of some files as well.
  2. Samba server on the PC, starting only when needed and accessing it directly from the phone using mixplorer; also backing up app’s using samba as cloud drive for SwiftBackup.
1 Like

My go to is always using mtp and if this fails I normally just put my micro SD into my reader and copy this way. I used to use KDE connect but haven’t for a while now as I don’t often have the need I once did to transfer files between these devices

1 Like