Is there an Nvidia enabled ISO for latest release with online installer?

Hello everyone!

I built myself a new computer and would like to try a rolling linux distribution to make use of the power management features, etc. my new board has. So far I used Ubuntu which only gets updated twice a year. So after some research I decided to give Endeavour OS a try.

I downloaded the latest ISO (2019.12.22) and put it on a USB stick via dd, but I’ve the same problem as mentioned in Live USB problems [SOLVED] .
The boot menu of the live USB shows up fine, but when I select the first option I get the same result as in the first picture in the above mentioned thread (1st post).
When I edit the grub menu entry and add modprobe.blacklist=nouveau to it then I can actually see the output flashing by on the whole screen until I get to the same state as shown in the 2nd pictured in the thread (3rd post).

Then I used the older nvidia enabled ISO (I got a Zortaq RTX 2060 Super) that @joekamprad provided in the same thread (http://endeavour.kamprad.net/beta/endeavouros-devel-nvidia-2-2019.07.20-x86_64.iso).
That one worked for me, but unfortunately it doesn’t have the online install option with the additional DEs.

Does anyone know if there’s an nvidia enabled ISO for the most recent release that contains the online installer somewhere?

Thanks heaps,
Marcel

That is the only nvidia enable ISO that was put out by @joekamprad as a courtesy at the the time early on. Unfortunately you also have one of the newer RTX Nvidia cards that seem to not want to work with the the current ISO that has the online installer. I don’t know what desktop you want to install but there are a couple of options. You could install Xfce first with the Nvidia enabled ISO and then install another desktop. Then you could remove Xfce.

Do you have secure boot and fast boot disabled?

Is this the only GPU on the machine? If you have a motherboard integrated onboard GPU you could connect this one to a display to install. Then you can check Nvidia drivers to be Installed from netinstall.
I could also build an Nvidia enabled ISO but this may need some days as I do not have much time to do so at the moment

You could try also use the old Nvidia ISO, and update welcome and calamares, what could work to get netinstall available

Thank you both for your replies.

Sorry, I should have mentioned that I’ve secure boot and fast boot disabled. I saw that this is a common question.

It is the only GPU on the machine. The board has no integrated GPU.

Are you saying that I should start the old Nvidia ISO and when the live system is up try to run some commands to update ‘welcome’ and ‘calamares’, which then would make the installer behave like the installer of the latest release?

Is it very complicated to make an nvidia enabled ISO or is it just labor-intensive?
If there’s a guide that I can follow somewhere I am happy to create the ISO.

Thanks again for the help,
Marcel


i just build one …

test is working as you can see, i will share the link for download in one hour!

2 Likes

endeavouros-nvidia-2020.01.12-x86_64.iso
endeavouros-nvidia-2020.01.12-x86_64.iso.md5sum
endeavouros-nvidia-2020.01.12-x86_64.iso.sig

4 Likes

Awesome!
Thank you very much, @joekamprad!
I am downloading it right now and will try to install it later today.
I’ll give feedback afterwards here on how it went.
Thanks again. Much appreciated!

2 Likes

Thank’s for being patient and welcome. We hope the journey is a blast! :laughing:

Well, that worked flawlessly!
In fact I am writing this post from my freshly installed Endeavour OS. :slightly_smiling_face:
Thanks heaps again!

I’ve another question now, but I’ll create another thread for it.

2 Likes