Is there an *easy* way to make the EndeavourOS installer Secure Boot compatible?

Got the new Xiaomi RedmiBook Pro 14 in today. Interestingly, it has Secure Boot enabled permanently in the BIOS. The option to turn it off is disabled. There are VERY few options in the BIOS, so looks like they’ve disabled being able to use non-secure boot compatible OS’s. I was going to use Endeavour on here, but of cousre, the USB isn’t secure boot compatible, thus can’t install since can’t boot to the installer.

Xiaomi RedmiBook Pro 14 secure boot

The Xiaomi RedmiBook Pro 14 has a secure boot feature that is enabled by default. This feature ensures that the laptop boots only with authorized operating systems and prevents unauthorized software from running during the boot process.

To disable the Secure Boot feature on your Xiaomi RedmiBook Pro 14, you can follow these steps:

  1. Enter the UEFI menu: Press the F2 key during boot to enter the UEFI menu.
  2. Select Security: Use the arrow keys to navigate to the “Security” section and press Enter.
  3. Disable Secure Boot: Highlight “Secure Boot” and press Enter to disable it.

Alternatively, you can also disable Secure Boot temporarily by pressing the F2 key during boot and following the on-screen instructions.

It’s important to note that disabling Secure Boot may compromise the security of your laptop and may allow unauthorized software to run during the boot process. Therefore, it’s recommended to only disable Secure Boot if you have a specific reason to do so and are aware of the potential risks involved.

I got this from a quick websearch with no way to verify

Yeah, that option is disabled. Greyed out, can’t select, won’t go to it. Cannot be changed.

Yer as I said I can’t test a thing with this. Have you checked the wbsite for the device to see if it can shed any light, bit weird for this to be locked down in BIOS/UEFI

I have emailed the Xiaomi support, yes. Figured I’d ask here at the same time since if there’s an easy way to make it secure boot compatible, then who cares if they reply or not.

1 Like


I hope you fixed the problem in theese months, here is the solution for anyone having the same problem.

In Xiaomins BIOS secure boot option is locked. You can find the option in “security”.

To unlock the option go to set a password for bios settings, once you create your password, you can disable secure boot. Then after that go to change password and put the old password but leave “new password” in blank.

Now secure boot option is again locked, but disabled instead of enabled.

Good luck!
from here

not sure if same device


There IS an option for supervisor password…let me try. I’ll post back in a couple.

Like I said before these are all guesses from websearches I would run to look for a solution, hope it works for ya

My uneducated guess is that you would need to build a custom ISO with a signed bootloader and kernel.

It did indeed!! That is possibly the stupidest BIOS option I’ve ever seen!! But indeed, set supervisor password on BIOS and it unlocks multiple OTHER options, most importantly of which is disabling secure boot.

Then can go right back in and disable supervisor password, and it keeps secure boot disabled, and again disables the option to change it.

Great find, thank you!!!

1 Like

You’re welcome mate

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.