Is there a way to disable the "No internet connection" pop-up?

Hey gang,
I use Gnome on all of my machines, some of which are not online but accessible on the LAN.
Upon booting, I always get that pop-up asking me to continue without internet connection and I wonder if there is a way to turn that off?

Hmmm, you could try the Gnome Settings app, click the tab “Notifications” and look for “Network” by default it’s notification is set to ON, so maybe try turning that off. You can simply click Notification, a popup will display showing a few settings, and you can just uncheck the first setting on the top to turn all notifications off for Network. Then doing a restart and log back in and see if that makes the popup go away. Let me know.

Turn this top setting to off to disable all Network notifications. My is currently set to ON since I use it:

WOW, you have a lot of notifications. Anyway, I think it’s something the EOS creators have added and thus can be disabled somewhere.

If you could show a screenshot of the popup, that may be helpful. Without knowing what version of Gnome (you have no internet on this machine so I’m assuming it’s not current?), you can try to disable the network manager notifications manually via gsettings or through dconf editor. For the former, just run these two commands one at a time as is:

gsettings set org.gnome.nm-applet disable-disconnected-notifications "true"

gsettings set org.gnome.nm-applet disable-connected-notifications "true"

Restart again and see if the message still appears or not. If it still shows up, then we might have to dive into some dconf editor settings, but dconf editor is not installed by default, fyi. Let me know if the above two commands work for you or not.

Could you show screenshot(s) about those pop-ups?
Some EndeavousOS apps may give them for you if internet connection is missing.
I could add some configuration setting for those if needed… :wink:

2 Likes

I would imagine that Welcome would complain - but I don’t know that it is a notification… one more thing to check!

sorry for the delay, but our clan grew by one baby over night! :slight_smile:
OK, here’s the deal. I run a handful of computers (all on EOS/Gnome) and some of the machines are configured to use LAN only because I do not want them to connect to the internet.
Every time I power a machine on that is offline, I get this popup:
noInternetConnection

And every time I “Continue anyway”.
so I was just wondering if there is a simply method to disable this?

Thanks guys.

Looks like the Welcome app to me. Might need any update! But before we get to that, try this first:

Lets dive back into the Gnome Settings. Instead of the Notifications section, select “Applications”

That’ll show all the applications on your system that you can configure notifications for on a per app basis. Go all the way to the bottom to find the Welcome app with the EndeavourOS logo and then deselect the notification toggle here:

Restart again and see if that does the trick or not and let us know!

1 Like

Update!
I celebrated too early. After going to that PC to do something, the warning messages greeted me again. Seigh …
Anyway, tomorrow is a new day. Back to work!!!


I am glad I asked (almost didn’t).
That did the trick. Thank you Scotty_Trees :slight_smile:

For anyone who happens to read this in 100’s of years from now …
Under Gnome > Settings > Network > Wired (Cog wheel) > IPv4 there is a check mark at the bottom which says: Use this connection only for resources on this network.
I check this for any of the computers which don’t need to be online and after applying the fix Scotty suggested, the pop-up no longer displays. Life is good!

1 Like

You can set variable

EOS_WELCOME_CONNECTION_WARNING

in file /etc/eos-script-lib-yad.conf to “no”.

3 Likes

He’s already marked the solution, you’re too slow! :wink:

But in all seriousness, that is useful information to know if ever a user doesn’t have/want an internet connection to the system, they can still manually edit the conf file to prevent the notifications instead of the alternative of having to connect to the internet and update the system to the latest Welcome app.

2 Likes

Thank you everyone for helping. It’s a small thing but to click this away on multiple machines every day made me wonder if there is a better way and there is.

@manuel
I just tested your suggestion and the edit you provided indeed fixes the pop-up. Thank you!

2 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.