Is there a way to avoid some messages are logged in the journal?

I am trying to understand why Firefox sometimes stops to work and I cannot open anymore applications. (Even selecting System > Shut down… doesn’t have any effect, apart showing the dialog box to choose between Suspend, Hibernate, Restart, Cancel, and Shut Down.)

I have asked a question, where I was asking to show the output of journalctl -b -1, but unfortunately the journal is flooded with unrelated error messages, and I cannot see if there are error messages that would explain what happens with Firefox.

Is there a way to temporary avoid these error messages are logged in the journal?

kernel: pcieport 0000:00:1c.6:    [ 0] RxErr                  (First)
kernel: pcieport 0000:00:1c.6: AER: Corrected error received: 0000:00:1c.6
kernel: pcieport 0000:00:1c.6:   device [8086:a116] error status/mask=00000001/00002000
kernel: pcieport 0000:00:1c.6:    [ 0] RxErr                  (First)
kernel: pcieport 0000:00:1c.6: AER: Multiple Corrected error received: 0000:00:1c.6

(I left out the timestamp and the host name part.)

I don’t mean to ignore those messages forever; I just need to be able to see error messages that could explain what happens with Firefox.

Well, you could filter for a specific term by piping the command through grep:

journalctl -b -1 | grep firefox

Is that what you’re looking for?


journalctl -g firefox

for entries related to firefox from past few boots.

The problem is that the journal is literally flooded by those messages. When I run journalctl I don’t see any other message.

I would check if there is a Bios update for this machine first and foremost. Update it and see if there are still any problems. Then if issue still exists i would try this kernel parameter. This should rid the error messages. Then see what other problems still exist.


I know the BIOS has been updated when I still had Windows 10 Pro installed on this computer.
How do I check, with Endeavour OS, if there are BIOS updates?

Before I forget: I also changed to the LTS kernel, before asking this question, but after asking the question about problems with opening new applications.

I don’t know what your system is. Post a link for the hardware.

inxi -Faz | eos-sendlog

Looks like it is updated to the latest.

Edit: So i would try the kernel parameter.


I assume you are using grub bootloader? Hopefully you are past the grub issues?

Add this to the default grub command line in /etc/default/grub
Then update grub with sudo grub-mkconfig -o /boot/grub/grub.cfg

1 Like

I am past the GRUB issue thanks to the pinned post shown here.

I edited the /etc/default/grub file to change the following line.

GRUB_CMDLINE_LINUX_DEFAULT="resume=UUID=d510aca6-3616-478f-bcba-d84439b35f82 loglevel=3 nowatchdog nvme_load=YES nvidia-drm.modeset=1"

After the edit, that line became:

GRUB_CMDLINE_LINUX_DEFAULT="resume=UUID=d510aca6-3616-478f-bcba-d84439b35f82 loglevel=3 nowatchdog nvme_load=YES pci=noaer nvidia-drm.modeset=1"

I then ran sudo grub-mkconfig -o /boot/grub/grub.cfg, but before that command could return, the bug I am trying to fix hit me.
I restarted the computer using the Magic SysRq Key as suggested on Sometimes, Endeavour OS stops opening new applications - #6 by Pudge, I re-ran sudo grub-mkconfig -o /boot/grub/grub.cfg (which was able to terminate), and I restarted my computer.

I can report the journal isn’t flooded anymore with those messages. I can see many messages I was not seeing before this change, and finally (I hope :wink:) understand what exactly the issue with Firefox is.

I have no issues with Firefox. I would suggest that it is some other hardware issue causing this.

Edit: It could be related to PCIe ASPM possibly but i don’t know. I’m just guessing at this point. :man_shrugging:

So far, I could just see it happens when Firefox is open and left open for some time.
When I use Vivaldi, I don’t have that issue, but then the shared memory (4.1 GB) is completely filled. (That doesn’t happen with Firefox.)

Hopefully, the journal will now tell me what happens.

Thank you for helping me with this. Without your help, I would have just kept reading error messages about this AER (which I still have to understand what that is :wink:, since Windows never told me I had one on my computer :stuck_out_tongue_winking_eye:).

pci=noaer is a kernel boot option can be used to disable the use of PCIE advanced error reporting. It basically hides the error messages. There seems to be an issue with pci-e hardware. It could be and most likely is a flawed Bios implementation. Since there are no newer Bios updates and highly unlikely there will be for that motherboard as it is getting dated. I suggest you keep using the system and paruse the logs to try to see if you can identify anything that may be the problem. Keep in mind that not all errors you see are a problem. Some are just informational.

Good Luck!

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.